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1. システム概要 

 

SVO とは画像データなどのデジタルデータを出力するイメージ・ジェネレーター・システムで

Windows 上のソフトウェアとハードウェア及びファームウェアから構成されます。 

本システムをお使いになることで、画像データの受信処理、画像処理などがカメラなどのデバ

イスがない状態で評価することが可能になります。 

下図にシステム構成および SVO ハードウェア画像を示します。 

 

システム構成図 

 

SVO ハードウェア画像 
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2. 動作環境 

 

○ ハードウェア 

PC   ： PC/AT 互換機 

CPU           Pentium 系 1GHz 以上 

Celeron 系 2GHz 以上 

または同等の互換 CPU 

メモリー        512 メガバイト以上（1ギガバイト以上推奨） 

ハードディスク空き容量 1 ギガバイト以上 

USB 仕様        2.0 必須  ※VIA 製チップでは保証できません 

モニタ ： フルカラー表示可能なもの 

他   ： USB2,0 ケーブル、ACケーブルなど 

 

○ ソフトウェア 

OS   ： WindowsXP SP1 以上、Windows7 

    ：  64bit 版ドライバー、アプリは Windows7 でのみ動作検証しています 

他   ： 弊社提供アプリケーション、ライブラリー、デバイスドライバー 
 

3. 必要なソフトウェア 

 

SVO システムを動作させるために必要な弊社提供のソフトウェアは以下の通りです。 

 

・SVOGenerator.exe 

  弊社専用の画像データファイルを読み込み表示を行い、この画像データをターゲット・ボ 

ードへ指定タイミングで出力することができるアプリケーションです。 

 

・SVOUSB20.dll 

  SVOシステム専用のUSB2.0デバイスドライバーを使用したSVO画像出力ライブラリーです。 

  上記アプリケーションを使用せず、お客様システムに本ライブラリーを組み込むことも可 

能です。 

 

・SVOUSB20.sys、SVOUSB20.inf 

  32bit 版 SVO システム専用 USB2.0 デバイスドライバーファイルです。 

 

・SvoUdrv.dll、SvoUdrv.inf、．．． 

  64bit 版 SVO システム専用 USB2.0 デバイスドライバーファイルです。 
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4. SVOハードウェア概要 
 

SVO ハードウェア（SVO-02）には①ルネサステクノロジー製マイコン（SH-7440F、44MHz）、②

ALTERA 製 FPGA（Cyclone）、③PLX テクノロジー製 USB2.0 コントローラ（NET2272）、④SDRAM

（128MB または 256MB）が実装され、イメージ・ジェネレーターを実現しています。 

 
 

ホスト PCとは⑤USB ポートにて接続します。また SVO の出力先となるターゲットボードとは⑥

50 ピンヘッダーで接続します。 

① ルネサステクノロジー製マイコン（SH-7440F、44MHz）は SVO ハードウェアの全体管理を行

います。 

② ALTERA 製 FPGA（Cyclone）は SDRAM 制御、イメージ・ジェネレーター処理、バス管理を行

います。 

③ PLX テクノロジー製 USB2.0 コントローラ（NET2272）はホスト PCとの USB インターフェー

スを行います。 

④ SDRAM（128MB または 256MB）は出力する画像データなどを格納します。 
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5. インストール 
 

SVO ハードウェアに同梱されています、ソフトウェア CD－ROM に必要なソフトウェアが格納さ

れています。この CD-ROM の内容は下表の通りです。 

 

フォルダ 内容 

\ readme.txt、version.txt を格納しています 

\SVO-AP アプリケーション、ライブラリー関連を格納しています 

\SVO-AP_x64 上記 64bit 版を格納しています 

\DRIVER SVO 専用 USB2.0 デバイスドライバー関連を格納しています 

\Driver_x64 上記 64bit 版を格納しています 

\Firm&FPGA SVO ボード用の最新ファームウェア、最新 FPGA データを格納しています 

\DOC 各種ドキュメントを格納しています 

\画像出力ﾗｲﾌﾞﾗﾘ 画像出力ライブラリーファイルを格納しています 

\Tool フレームファイルコンバーターユーティリティーを格納しています 

 

5.1. SVO 専用 USB2.0 デバイスドライバーのインストール 

 

①SVO ボードに ACケーブルを接続します。 

②SVO ボードと PCの USB2.0 インターフェースポートを USB ケーブルで接続します。 

③SVO ボードの電源を ONにします。 

 
 

④“新しいデバイスが見つかりました”のメッセージが表示され“SVO USB2.0 Device”と表示されま

す。この後“新しいハードウェアの検出ウィザード”ウィンドウが表示されます。（例：WindowsXP） 
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“いいえ、今回は接続しません“を選択し、”次へ“ボタンをクリックします。 

 

⑤CD-ROM を挿入し、“一覧または特定の場所からインストールする“を選択し、”次へ“ボタンをクリ

ックします。 

 
“次の場所で最適のドライバを検索する”を選択し、“リムーバルメディア（フロッピー、CD-ROM など）

を検索”にチェックをし、”次へ“ボタンをクリックします。（”次の場所を含む“チェックは外しま

す） 
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⑥デバイスドライバーのインストールが開始されます。 

 
インストールが完了すると下図の表示になりますので、“完了”ボタンをクリックします。 

 
完了ボタンを押すと、ウィンドウが閉じ、下図のように“新しいハードウェアがインストールされ、使

用準備ができました”と表示されます。 
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⑦デバイスドライバーのインストールが正常に行われたどうか、デバイスマネージャでも確認されるこ

とを推奨します。デバイスマネージャのウィンドウで下図のように表示されていれば問題ありません。 

 
 

 

※Windows7 64bitへのドライバーインストールはCD-ROMの Driver_x64に格納のデバイスドラ

イバーをご使用ください。 

 

5.2. アプリケーション、ライブラリー関連のインストール 

 

CD-ROM 内の SVO-AP フォルダをハードディスクの任意の場所へコピーしてください。 

念のためコピー先のSVO-APフォルダの属性が読み書き可能になっているのを確認して下さい。 

 

※Windows7 64bitは CD-ROMの SVO-AP_x64フォルダに格納されています。使用方法は同一です。 

 



                       SVO システムソフトウェアマニュアル Rev.1.34 

NDC00012 

 

Net Vision Corp. 

 

11 

 

6. アンインストール 

 

SVO 専用 USB2.0 デバイスドライバーのアンインスト－ルとアプリケーションの削除の手順に

ついて説明します。 

SVO のアンインストールは通常は 6.2「アプリケーション、ライブラリー関連のアンインスト

ール」のみを行ってください。PC上から完全にSVOをアンインストールしたい場合のみ6.1「SVO

専用 USB2.0 デバイスドライバーのアンインストール」を行ってください。 

 

6.1. SVO 専用 USB2.0 デバイスドライバーのアンインストール 

 

SVO 専用デバイスドライバーのアンインストールについて、デバイス削除、レジストリ削除、

ドライバ削除の３つにわけて手順を示します。 

デバイスドライバー削除の際にはこの３つの手順を実施してください。デバイスドライバーの

アンインストールにはレジストリ操作を行いますので必要であればレジストリのバックアッ

プを作成してください。またアンインストールは削除権限のあるユーザで実行してください。 

 

＜デバイス削除＞ 

 

①SVO ボードに ACケーブルを接続します。 

②SVO ボードと PCの USB2.0 インターフェースポートを USB ケーブルで接続します。 

③SVO ボードの電源を ONにします。 

  
 

④デバイスマネージャを開きます。 

4-1.【スタート】→【コントロールパネル】→【システム】を選択します。 

4-2.“システムのプロパティ”ダイアログが表示されるので“ハードウェア”タブを選択し

ます 
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4-3.“デバイスマネージャ”ボタンを押します。 

 
 

⑤“SVO USB 2.0 Device”をデバイスマネージャから探し選択します。 

 
※SVO ボードを USB で PC と接続し、ボードの電源を ONにしていないと表示されません。 

⑥“SVO USB 2.0 Device”で右クリック、表示されるメニューから“削除”を選択します。 

 
 

⑦デバイスの削除の確認ダイアログが表示されるので、“OK”をクリックします。 
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⑧削除されたことを確認します。（デバイスマネージャに表示されていないことを確認） 

 
 

⑨SVO ボードの電源を OFF にします。 

以上でデバイスの削除は終了です。 

 

＜レジストリー削除＞ 

 

①レジストリーエディターを起動します。 

1.1【スタート】→【ファイル名を指定して実行】 

1.2 表示されるダイアログに“regedit”と入力し OKをクリック 

②レジストリーエディターで以下のキーを捜します。 

“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SVOUSB20” 

③“右クリック”で表示されるメニューから“削除”を選択し、キーを削除します。 

 
 

以上でレジストリの削除は終了です。 
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＜ドライバ削除＞ 

 

①エクスプローラを起動します。 

【スタート】→【プログラム】→【アクセサリ】→【エクスプローラ】 

 

②エクスプローラで以下のファイルを捜します。 

“C:\WINDOWS\system32\drivers\SVOUSB20.sys” 

③“右クリック”で表示されるメニューから“削除”を選択し、ファイルを削除します。 

 
 

以上でドライバの削除は終了です。 

 

6.2. アプリケーション、ライブラリー関連のアンインストール 

コピーした SVO-AP フォルダを削除してください。SVO-AP フォルダ内のアプリケーションレジ

ストリへの書込みを行いません。そのためフォルダの削除により、アプリケーション、ライブ

ラリ関連のアンインストールが完了します。 
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7. SVO ボード・ディップスイッチ設定 
SVO システムのソフトウェアは、1台の PCに複数の SVO ボードが接続されることを想定してい

ます。当初のソフトウェアでは、複数の SVO ボードから 1つだけ選択し使用することができま

す。将来的には同時に複数の SVO ボードを使用できるようするつもりでいます。 

そこで、複数の SVO ボードが接続された時に、それぞれの SVO ボードを識別するために、SVO

ボード上のディップスイッチ“S2“にて番号を付けることができます。番号は 00 から 1fまで

で、下表の設定になっています。（S2-8 番から 4番までを使用） 

 

番号 S2-8 S2-7 S2-6 S2-5 S2-4 S2-3 S2-2 S2-1 Device-Select 表示 About Dialog 表示 

0 OFF OFF OFF OFF OFF OFF OFF OFF 0000 0000xxxx 

1 OFF OFF OFF OFF ON OFF OFF OFF 0001 0001xxxx 

2 OFF OFF OFF ON OFF OFF OFF OFF 0002 0002xxxx 

3 OFF OFF OFF ON ON OFF OFF OFF 0003 0003xxxx 

4 OFF OFF ON OFF OFF OFF OFF OFF 0004 0004xxxx 

5 OFF OFF ON OFF ON OFF OFF OFF 0005 0005xxxx 

6 OFF OFF ON ON OFF OFF OFF OFF 0006 0006xxxx 

7 OFF OFF ON ON ON OFF OFF OFF 0007 0007xxxx 

8 OFF ON OFF OFF OFF OFF OFF OFF 0008 0008xxxx 

9 OFF ON OFF OFF ON OFF OFF OFF 0009 0009xxxx 

10 OFF ON OFF ON OFF OFF OFF OFF 000A 000Axxxx 

11 OFF ON OFF ON ON OFF OFF OFF 000B 000Bxxxx 

12 OFF ON ON OFF OFF OFF OFF OFF 000C 000Cxxxx 

13 OFF ON ON OFF ON OFF OFF OFF 000D 000Dxxxx 

14 OFF ON ON ON OFF OFF OFF OFF 000E 000Exxxx 

15 OFF ON ON ON ON OFF OFF OFF 000F 000Fxxxx 

16 ON OFF OFF OFF OFF OFF OFF OFF 0010 0010xxxx 

17 ON OFF OFF OFF ON OFF OFF OFF 0011 0011xxxx 

18 ON OFF OFF ON OFF OFF OFF OFF 0012 0012xxxx 

19 ON OFF OFF ON ON OFF OFF OFF 0013 0013xxxx 

20 ON OFF ON OFF OFF OFF OFF OFF 0014 0014xxxx 

21 ON OFF ON OFF ON OFF OFF OFF 0015 0015xxxx 

22 ON OFF ON ON OFF OFF OFF OFF 0016 0016xxxx 

23 ON OFF ON ON ON OFF OFF OFF 0017 0017xxxx 

24 ON ON OFF OFF OFF OFF OFF OFF 0018 0018xxxx 

25 ON ON OFF OFF ON OFF OFF OFF 0019 0019xxxx 

26 ON ON OFF ON OFF OFF OFF OFF 001A 001Axxxx 

27 ON ON OFF ON ON OFF OFF OFF 001B 001Bxxxx 

28 ON ON ON OFF OFF OFF OFF OFF 001C 001Cxxxx 

29 ON ON ON OFF ON OFF OFF OFF 001D 001Dxxxx 

30 ON ON ON ON OFF OFF OFF OFF 001E 001Exxxx 

31 ON ON ON ON ON OFF OFF OFF 001F 001Fxxxx 

 

“xxxx”には Windows が認識し割り振った番号が 0から Fの範囲で付与されます。 
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8. アプリケーション操作方法 
SVOGenerator を使った、基本的なアプリケーションの操作の一連の流れと個別の操作方法を説

明します。またアプリケーションの項目の詳細についてはアプリケーションのヘルプも参照し

てください。 

 

8.1. アプリケーション操作の流れ 

SVO デバイスからデータを出力するまでの基本的な流れを示します。この手順を実行すること

により SVO デバイスからデータを出力することができます。またそれぞれの各項目については

次節以降を参照してください。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

アプリケーション（SVOGenerator）の起動 

ファイルオプション（解析情報）設定 

データファイルの読込み 

データ確認 

SVO ボード選択 

SVO ボード設定情報作成 

SVO ボードへのデータ送信 

SVO ボードの操作 

アプリケーション（SVOGenerator）の終了 
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8.2. アプリケーション（SVOGenerator）の起動 

 

①5.2“アプリケーション、ライブリー関連のインストール”でコピーした SVO-AP フォルダ

内にある“SVOGenerato.exe”を実行します。 

②下図の SVOGenerator の画面が表示されます。表示された SVOGenerator のステータスバー

に“Ready”と表示されていることを確認します。 

 
以上で起動終了です。 

 

8.3. アプリケーション（SVOGenerator）の終了 

 

①“File”→“Exit”をクリックするか、画面右上の“×”ボタンをクリックします。 

 
以上でアプリケーションは終了です。 
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8.4. ファイルオプション（解析情報）設定 

 

①“File”→“Option”をクリックするか、ツールバーの アイコンをクリックします。 

②“File Option”ダイアログが表示されるので、これから読み込むデータファイルにあっ

た設定を行います。 

 
③設定が終了したら“OK”ボタンをクリックします。 

 

※ファイルオプションの設定はデータファイルを読み込んだ後でも変更可能です。その場合 

 “OK”ボタンをクリック後 File Option の設定を元に画像データの再解析を実行します。 

※”RAW(10,12,14)Data Mode”グループの”Byte Swap(FRM Only)”をチェックすると、出力

時、LowByte、HighByte を入れ替えて出力することができます。 
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8.5. データファイルの読込み 

 

①“File”→“Open”をクリックするか、ツールバーの アイコンをクリックします。 

②“ファイルを開く”ダイアログが表示されるので、適切なファイルを選択します。 

 
※SVI で作成したファイル以外のファイルを開いた場合、アプリケーションの動作が不安定

になることがあります。その場合は再度アプリケーションを終了し起動しなおしてくださ

い。 

③File Option の設定を基に、データの解析を行います。終了すると画像を表示します。 

 
※解析が正常に終了するとステータスバーに“Analyze Complete”と表示されます。 

解析が途中で異常終了した場合ステータスバーに“Analyze Incomplete”と表示されます 
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8.6. データ確認 

 

①“View”→“Play”または、ツールバーの アイコンを選択しデータを１フレームずつ

確認します。 

 
②ステータスバーには現在表示中のフレーム番号、画像サイズが出ていますので、再生中に

適宜参照してください。 

②画像データのフレームを飛ばしながら確認したい場合には“View”→“Jump To” 

画像データの色を確認したい場合には“View”→“Color Bar” 

ファイルのヘッダ情報を参照したい場合には“View”→“File Information” 

で確認してください。 

ステータスバーや各ダイアログの詳細は SVOGenerator の Help を参照してください。 
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8.7. SVO ボードの選択 

 

①“Device”→“Select”クリックするか、キーボードの“F3”、またはツールバーの を

押します。 

 
②“Device Select”ダイアログが表示されます。ドロップダウンリストに現在 USB ポート

に接続されている SVO ボードの識別 IDが表示されますので、制御を行うボードの ID を選

択します 

 
※表示される ID は USB ポートに接続している SVO ボードにより異なります。 

③IDの選択を行ったら、“Select”ボタンを押します。 

 
以上でデバイス選択は終了です 
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8.8. SVO ボードの設定情報作成 

 

①“Device”→“Setting クリックするか、キーボードの“F4”または、ツールバーの ア

イコンをクリックします。 

 
②“Device Setting”ダイアログが表示されます。各設定項目を設定します。 

 
※上図赤枠の設定については、“12.Device Setting 詳細”をご参照下さい。 

※”SAVE SET”ボタンは現在の DeviceSetting 内容を任意のファイルへ保存することができ
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ます。 

※”RESTORE SET”ボタンは任意の DeviceSetting ファイルを読み込むことができます。 

③設定が終了したら“SET”ボタンを押します。 

 
以上で設定は終了です。 
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8.9. SVO ボードへのデータ転送 

 

①“Device”→“Picture Send”をクリックするか、キーボードの“F5”または、ツールバ

ーの を押します。 

 
※ただし 7.7“SVO ボード選択”が終了していないと選択することはできません。 

②データ転送が始まります。転送中はステータスバーに“Picture Send Start”と表示され

マウスアイコンが砂時計になります。 

また転送中は SVO ボードの LED ランプ“ACC”が点滅します。 

③ステータスバーに“Picture Send Complete”と表示されれば転送終了です。 

また SVO ボードの LED ランプ“ACC”が消灯します。 

 
以上でデータ転送終了です。 
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8.10. SVO ボードの操作 

①“Device”→“Control”またはツールバーの アイコンをクリックします。 

 （キーボードの“F6”を押しても選択できます） 

  
②“Device Control”ダイアログの“Play Setting”に SVO ボードからのデータ送出条件 

 を設定します。 

 
③設定が終了したら、“PLAY”ボタンを押します 

 
④“Play Cycle”で設定した回数データ送出が終了します。 

また“Infinity”にチェックをつけた場合には終了したいところで“STOP”ボタンを押し

ます。 

 各ボタンなどの詳細については SVOGenerator の Help を参照してください。 
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8.11. SVO ボードのファームウェアアップデート方法 

SVOボードのファームウェアのアップデートを行います。アップデートを行う前に SVOボードのディップスイッチS3を下

図のように設定してください。 

 

 

手順１．SVO ボードのディップスイッチ S3 を上図のように設定してから SVO ボードの電源を投入してください。 

手順２．SVOGenerator を起動してください。 

手順３．Device メニューの Select をクリックして、アップデートを行う、SVO ボードを選択してください。 

 ※ダイアログの ID 表示はソフトウェアのバージョンにより４桁の場合もあります 

手順４．Tool メニューの Firmware Update をクリックしてください。 

 

手順５．ファイル選択ダイアログが表示されますので、so○fwxxx.bin を選択し開くボタンをクリックしてください。 

手順６．マウスカーソルが砂時計に変わります。しばらくすると砂時計が矢印しに戻り、下図の完了メッセージが表示さ

れます。この時 SVO ボード上のディップスイッチ S4 の隣の ACC ランプが完全に消灯したかを確認します。 
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手順７．OK ボタンをクリックし、SVOGenerator を終了してください。 

手順８．SVO ボードの電源を切ります。 

手順９．ディップスイッチ S3 を下図のように通常状態に戻してください。 

 

 

注意：ファームウェア・アップデートと FPGA アップデート、PLL アップデートは連続して実行することはでき

ません。 
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8.12. SVO ボードのＦＰＧＡアップデート方法 

SVO ボードの FPGA のアップデートを行います。アップデートを行う前に SVO ボードのディップスイッチ S3 を下図のよ

うに設定してください。 

 

 

手順１．SVO ボードのディップスイッチ S3 を上図のように設定してから SVO ボードの電源を投入してください。 

手順２．SVOGenerator を起動してください。 

手順３．Device メニューの Select をクリックして、アップデートを行う、SVO ボードを選択してください。 

 ※ダイアログの ID 表示はソフトウェアのバージョンにより４桁の場合もあります 

手順４．Tool メニューの FPGA Update をクリックしてください。 

 

手順５．ファイル選択ダイアログが表示されますので、so○fpgaxxx.bin を選択し開くボタンをクリックしてください。 

手順６．マウスカーソルが砂時計に変わります。しばらくすると砂時計が矢印しに戻り、下図の完了メッセージが表示さ

れます。この時 SVO ボード上のディップスイッチ S4 の隣の ACC ランプが完全に消灯したかを確認します。 
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手順７．OK ボタンをクリックし、SVOGenerator を終了してください。 

手順８．SVO ボードの電源を切ります。 

手順９．ディップスイッチ S3 を下図のように通常状態に戻してください。 

 

 

注意：FPGA アップデートとファームウェア・アップデート、PLL アップデートは連続して実行することはでき

ません。 
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8.13. SVO ボードの PLL アップデート方法 

※注意  FPGA；130 以上、FW；103 以上でないとこの機能は使用することができません。 

SVO ボードの FPGA のアップデートを行います。アップデートを行う前に SVO ボードのディップスイッチ S3 を下図のよ

うに設定してください。 

 

 

手順１．SVO ボードのディップスイッチ S3 を上図のように設定してから SVO ボードの電源を投入してください。 

手順２．SVOGenerator を起動してください。 

手順３．Device メニューの Select をクリックして、アップデートを行う、SVO ボードを選択してください。 

 ※ダイアログの ID 表示はソフトウェアのバージョンにより４桁の場合もあります 

手順４．Tool メニューの PLL Update をクリックしてください。 

 

手順５．ファイル選択ダイアログが表示されますので、s○pllxxx.bin を選択し開くボタンをクリックしてください。 

手順６．マウスカーソルが砂時計に変わります。しばらくすると砂時計が矢印しに戻り、下図の完了メッセージが表示さ
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れます。この時 SVO ボード上のディップスイッチ S4 の隣の ACC ランプが完全に消灯したかを確認します。 

 

手順７．OK ボタンをクリックし、SVOGenerator を終了してください。 

手順８．SVO ボードの電源を切ります。 

手順９．ディップスイッチ S3 を下図のように通常状態に戻してください。 

 

 

注意：FPGA アップデートとファームウェア・アップデート、PLL アップデートは連続して実行することはでき

ません。 
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8.14. 8 ビット（16 ビット）出力設定方法 

8 ビット出力設定については、解析対象ファイル取得前後のどちらの状態でも実施することができます。 

また Memory Assign の設定を変更した場合には（8bit ⇔ 16bit）、下記の操作を実施してください。 

以下は 8 ビット出力の説明ですが、16 ビット出力設定の場合には 8 ビットを 16 ビットに読み替えてください。 

①“File”→“Option”をクリックするか、ツールバーの アイコンをクリックします。 

②“File Option”ダイアログが表示されるので、Sync Mode、Picture Type にこれから読

み込むデータファイルにあった設定を行います。Memroy Assign の選択を 8bit に設定し

ます。 

 
③設定が終了したら“OK”ボタンをクリックします。 

④“Device”→“Setting”または、ツールバーの アイコンをクリックします。 

⑤適切な Width(PCLK)と Height を設定します。 

注意：接続先デバイスが SVI の場合 Width(PCLK)の設定を画像サイズの倍の値に設定する必

要があります。 

 
⑥8.9の SVO ボードへのデータ転送を実施します。 

⑦8.10の SVO ボードの操作を実施します。このときの出力は 8bit が有効データとなります。 

※8bitに設定した場合、RAW-10bit, 

RAW-12bit, RAW-14bit, RAW Data 

Modeは無効になります。 

※16bitに設定した場合、FRMファイル

に限り、RAW Data Modeにより16ビット

中の上位バイトと下位バイトをスワップ

することができます。このスワップは

FRMデータを読み込む際に適用され

ます。 
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8.15. SVOGeneratorHelper ツールの使い方 

8.15.1. SendMemory Dump ダイアログ 

SendMemory Dump ダイアログは SVO ボード上のメモリ（SDRAM）にどのようにデータが格納され

ているかをシミュレートし表示したものです。データの表示移動方法としては、スクロールバ

ーによる移動とフレーム単位の移動、アドレス指定による移動の３種類をサポートしています。 

＜フレーム単位の移動＞ 

フレーム単位の移動はFrameNoのコンボボックスから移動したいフレーム番号を選択すること

により、描画ボックスの左上を選択したフレームの開始位置としてデータの描画を行います。 

＜アドレス指定＞ 

アドレス指定による移動は、Adress ボックスの中に 16 進数でアドレスを入力して、Enter キ

ーを押すことにより移動することができます。データ表示は、描画ボックスの左上を先頭に指

定したアドレスにあるデータが順番に表示されます。 

＜スクロールバーによる移動＞ 

描画ボックスの横にあるスクロールバーを上下に移動させることにより、データをスクロール

させることができます。ただし、スクロールバーをドラッグして移動させる場合には、データ

の更新がうまく行われないことがあります。その場合は一度ドロップすることにより描画を再

開します。 
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8.15.2. Output Wave Simulator ダイアログ 

Output Wave Simulator ダイアログは SVO ボードから出力される、VSync、HSync、DCK、PixelData、

を波形表示するものです。ただし、実際に SVO ボードから出力される信号を取得しているわけ

ではなく、取得した画像データや SVO ボードへの Setting 情報を元に波形をシミュレートした

ものです。そのため、簡易的に確認する場合に利用してください。詳細または、正確なデータ

が必要な場合にはロジックアナライザー等を出力ピンに接続してデータを確認する必要があ

ります。 

 
 

Output Wave Simulator で行えることは以下のことです。 

 シミュレート波形表示 

 波形の拡大（128 倍まで）・縮小（制限なし） 

 補助線描画 

 波形出力位置を画像の X,Y 座標への変換 

 画像 X,Y 指定しての表示位置の移動 

 経過時間表示 

各機能について使い方を説明します。 

 

＜波形の拡大縮小＞ 

描画波形を拡大または縮小することができます。拡大したいときには「ZoomUp」ボタンをおし

ます。縮小したいときには「ZoomDown」ボタンを押します。 

拡大については描画エリアの関係から 128 倍が最大拡大率になります。128 倍にすると表示さ

れるデータは１クロックに出力されるデータ波形となります。また縮小については特に下限を

設定してはいません。ただし PC の性能にもよりますが縮小率が、1/1024（0.000977）以下に

なるとダイアログの動作が極端に重くなります。これは描画データ計算処理の負荷が増えるた

めです。そのため縮小時は PCに負荷がかかり過ぎない程度に利用してください。 

 

＜補助線描画機能＞ 

「Additional Line」チェックボックスにチェックを付けると、描画エリア内をマウスが移動

する時に、マウス位置にあわせて赤い点線が描画されるようになります。この補助線はある位

置のデータを見る場合に、見やすいように直線を描画しているものです。 

補助線をマウスが移動しても固定しておきたい場合には、固定位置で左クリックを押します。

また解除したい場合には波形描画エリア内でもう一度左クリックを行います。 
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＜波形出力位置を画像の X,Y 座標への変換＞ 

ダイアログ下段にある「ViewImagePos」が XY座標への変換した場合の位置を表します。 

 

 
 

この位置は、描画エリア内にマウスがある場合には、マウスのポインタがある位置のデータが

画像のどこに当たるのかを表示しています。また SVOGenerator 本体から移動処理を行った場

合には画面左の位置にあるデータが画像のどこに当たるのかを表示しています。この描画計算

には SVOSetting ダイアログで設定したデータを利用しています。そのため、Setting が画像デ

ータと一致していない場合には、座標変換データもおかしな値になります。 

 

＜画像 X,Y 指定しての表示位置の移動＞ 

SVOGenerator.exe 本体の画像表示エリア内で右クリックを行うと、Output Wave Simulator の

波形表示位置を、右クリックした位置に当たる出力データを先頭に再表示を行います。 

 

 
 

 

 

 

 

この機能により、画像の X,Y 位置ではどのように波形が出力されているのかを、右クリックで

すばやく確認することができます。 

 

①マウス右クリック 

マウス位置座標 

②クリック位置座標が先頭に移動する 
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9. SVO ボード LED ランプ状況 
 

LED 名称 LED 状態 条件 

RDY 消灯 ・CameraPower、Power の両方が OFF 

・CameraPower が OFF、Power が ON（このとき Err が点灯） 

 点灯 ・CameraPower、Power の両方が ON 

ACC 消灯 ・USB 転送が行われていない 

 点滅 ・USB 転送が行われている 

ACT 消灯 ・データ未出力 

 点滅 ・データ出力中 

VSYNC 消灯 ・VSync 未出力 

 点滅 ・VSync 出力 

ERR 消灯 ・エラーなし 

 点灯 ・エラーあり 

CAMPOWER 消灯 CameraPower が OFF 

 点灯 CameraPower が ON 
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10. アプリケーション・エラーメッセージ一覧 
モニタリング、レコーディング、その他処理中にエラーが発生することがあります。アプリケ

ーションはエラーが発生した場合はメッセージボックスを表示し、ユーザへエラー発生を通知

します。エラー発生後、各処理に従い処理を終了します。以下の表にエラーメッセージ、エラ

ー発生の要因、対処法を記載します。また以下の項目は Help ファイルを参照してください。 

 

10.1. アプリケーションエラー 

項目番号 １ 

エラーメッセージ Device UnOpened 

エラー内容 SVO ボードの Open 処理に失敗 

エラー発生の要因 ・SVO ボードの電源が切れた 

・SVO ボードの異常 

・アプリケーションからボードが認識できない 

対処法 1.一度、アプリケーションを終了し、SVO ボードの電源を OFF にする 

2.ボードの電源を入れ、アプリケーション再立ち上げ 

 

項目番号 ２ 

エラーメッセージ Play Failure（ダイアログの２行目に SVOAPI エラーも表示） 

エラー内容 SVO デバイスからのデータ送出処理に失敗 

エラー発生の要因 ・SVO ボードが処理実行中 

・アプリケーションからボードが認識できない 

対処法 ・SVO ボードの処理が終了するまで待つ 

上記で対処できない場合は項目番号１の対処法を実行 

 

項目番号 ３ 

エラーメッセージ Shared Memroy UnOpen 

エラー内容 SVO メモリーデータ、画像表示用のメモリー領域が確保できない 

エラー発生の要因 仮想メモリー領域の不足 

対処法 仮想メモリー領域を増やす 

 

項目番号 ４ 

エラーメッセージ File Open Failure 

エラー内容 ファイル Open に失敗 

エラー発生の要因 ・指定されたファイルがーオープンできない。 

・既に別のアプリケーションでオープンされている 

・指定したパスにファイルが見つからない 

対処法 ・ファイルを使用していれば、使用を終了する 

・正しいファイルパスを設定する 

 

項目番号 ５ 

エラーメッセージ Update Incomplete 

エラー内容 FPGA もしくは Firmware のアップデートに失敗 

エラー発生の要因 ・SVO デバイスが Open できない 

・SVO ボードが処理中 

・ファイルデータが不正 

対処法 ・SVO ボードの処理を終了させる 

・ファイルを確認する 
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項目番号 ６ 

エラーメッセージ Not Data Analyze 

エラー内容 データ解析が終了していない 

エラー発生の要因 ・データを取得していない 

・ファイルのデータが解析できない 

対処法 ・データを取得する 

・ファイルを確認する 

 

項目番号 ７ 

エラーメッセージ Not Selected Device 

エラー内容 SVO ボード未選択 

エラー発生の要因 SVO ボードの選択を行っていない 

対処法 SVO ボードの選択を行う 

 

項目番号 ８ 

エラーメッセージ Not Idol 

エラー内容 SVO ボードが処理実行中 

エラー発生の要因 SVO ボードが処理を実行している 

対処法 SVO ボードの処理が終了するまで待つ。 

項目番号１の対処法を実行する 
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10.2. SVOAPI エラー 

項目番号 ９ 

エラーメッセージ Win32API Error（２行目にエラーの詳細情報） 

エラー内容 Windows の API エラー 

エラー発生の要因 詳細情報による 

対処法 詳細情報による 

 

項目番号 １０ 

エラーメッセージ Connect No Device or Power Off 

エラー内容 USB に SVO ボードがつながれていない。または電源が入っていない 

エラー発生の要因 ・SVO ボードが USB に接続されていない 

・SVO ボードの電源がはいっていない 

対処法 ・デバイスマネージャで SVOUSB20 が認識されていることを確認 

・SVO ボードを接続する 

・SVO ボードの電源を入れる 

 

項目番号 １１ 

エラーメッセージ Device Multi Open 

エラー内容 複数の SVO ボードを Open しようとしている 

エラー発生の要因 ・複数の SVO ボードを Open しようとしている 

・１つの SVO ボードに対して２重に Open しようとしている 

対処法 ・２重 Open していないか確認する 

・複数の SVO ボードを１つのアプリケーションで Open しようとしていな

いか確認する 

 

項目番号 １２ 

エラーメッセージ Device UnOpened 

エラー内容 SVO ボードが Open していない 

エラー発生の要因 Open していない SVO ボードに対して処理をしようとしている 

対処法 ・SVO ボードを Open する 

・Control ダイアログを閉じて、メニューの Control を選択する。 

 

項目番号 １３ 

エラーメッセージ Parameter Incorrect 

エラー内容 設定パラメータの異常 

エラー発生の要因 設定パラメータが間違っている 

対処法 設定パラメータの確認 

 

項目番号 １４ 

エラーメッセージ FW Update TimeOut 

エラー内容 Firmware アップデートに失敗 

エラー発生の要因 ・SVO ボードが処理中 

・ファイルデータが不正 

対処法 ・SVO ボードの処理を終了させる 

・ファイルを確認する 
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項目番号 １５ 

エラーメッセージ FPGA Update TimeOut 

エラー内容 FPGA アップデートに失敗 

エラー発生の要因 ・SVO ボードが処理中 

・ファイルデータが不正 

対処法 ・SVO ボードの処理を終了させる 

・ファイルを確認する 

 

項目番号 １６ 

エラーメッセージ Image Data Not Stored In SVO 

エラー内容 SVO ボードのメモリーにデータが格納されていない 

エラー発生の要因 SVO ボードのメモリーにデータが格納されていない 

対処法 SVO ボードへデータを転送する 

 

項目番号 １７ 

エラーメッセージ Command Busy 

エラー内容 SVO ボードが処理中 

エラー発生の要因 SVO ボードが処理実行中 

対処法 SVO ボードが処理が終了するまで待つ 

 

項目番号 １８ 

エラーメッセージ Command Incorrect 

エラー内容 規定されていないコマンドを SVO ボードに送った 

エラー発生の要因 規定されていないコマンドを SVO ボードに送った 

対処法 送信コマンドの確認 

 

項目番号 １９ 

エラーメッセージ Paramater Incorrect 

エラー内容 コマンドパラメータ不正 

エラー発生の要因 ・コマンドパラメータ値があっていない 

・パラメータの数が違う 

対処法 ・コマンドパラメータの確認 

 

項目番号 ２０ 

エラーメッセージ Command Not Supported 

エラー内容 規定されていないコマンドを SVO ボードに送った 

エラー発生の要因 規定されていないコマンドを SVO ボードに送った 

対処法 送信コマンドの確認 

 

項目番号 ２１ 

エラーメッセージ Not Idol 

エラー内容 SVO ボードが処理実行中 

エラー発生の要因 SVO ボードが処理を実行している 

対処法 SVO ボードの処理が終了するまで待つ。 

項目番号１の対処法を実行する 
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11. 制限事項 
 

項目番号 制限事項 回避策 

１ “Device Control”ダイアログの“Sync”チェ

ックをチェックした場合、SVOGenerator 画面が

SVO ボードデータ出力中の画像表示を行うが、

画面表示が SVO 出力データに対して遅延して表

示される。 

・高性能な PCにする。 

（処理上の遅延であるため根本

的な回避策はない） 

２ “Device Control”ダイアログの“Sync”チェ

ックをチェックし、“PLAY”中に“File Option”

ダイアログまたは“Device Setting”ダイアロ

グを表示するとメインウィンドウの背面に表示

されてしまう 

“File Option”または“Device 

Setting”ダイアログを表示した

場合は、キーボードの“Alt”キ

ーを押すと前面に表示される 

３ “Device Select”など SVO ボード関連の操作を

行ったときに“Win32API Error”が発生すると、

それ以降 SVO ボードへのアクセスが異常になる 

SVOGenerator を終了し、SVO ボー

ドの電源を OFF にする。その後

SVO ボードの電源を ON にし、

SVOGenerator を起動する 

４ “Device Setting”で解析対象画像の情報と異

なった設定を行うと、SVO ボードが異常動作を

することがある。 

異常動作を起こした設定を行わ

ないようにする 

５ “Device Control”ダイアログで“PLAY”動作

中に SVO ボードが異常動作をすると、STOP ボタ

ンなどが動作しなくなる 

SVOGenerator を終了し、SVO ボー

ドの電源を OFF にする。その後

SVO ボードの電源を ON にし、

SVOGenerator を起動する 
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12. FRM形式の画像データフォーマットについて 
 

ＳＶＯシステムで対応する画像データはＳＶＩシステムで作成されたＤＡＴ形式とＦＲＭ形

式があります。 

ＤＡＴ形式はピクセルクロック単位で画像を記録しており、クロック単位で同期信号情報１バ

イト、画像データ１バイトの２バイト単位で構成されます。ピクセルクロック単位の記録のた

め、ブランキング期間も記録できます。 

但し、ブランキング期間の記録とピクセルクロックごとの記録となり、記録できるフレーム数

が少なくなります。 

ＦＲＭ形式はカメラモジュールまたはイメージセンサから出力されたデータをフレームごと

に４０バイトのヘッダーが付加されたもので、フレームの前にヘッダーが記録されます。 

データ部はカメラから出力されたままを記録します。但しフレーム部のバイト数は６４で割り

切れるようパディングデータが付加されています。 

お客様でＳＶＩｖｉｅｗ又はＳＶＯＧｅｎｅｒａｔｏｒで読み込ませるために、ＳＶＩフォー

マットに変換される場合はＦＲＭ形式を推奨いたします。 

以下に、ＦＲＭ形式のＳＶＩ画像ファイルフォーマットの詳細を示します。 
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画像の階調が１０ビット、１２ビット、１６ビットのバイト並びはビックエンディアンとなり

ます。 

 

13. Device Setting 詳細 

 

“Device”-“Setting”メニューで表示される“Device Setting”ダイアログの設定と実際の

出力イメージについて解説します。 

下図の設定をした場合の出力イメージを次ページの図で示します。 
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Blanking Setting で設定される Horizontal は Hブランク期間で、Vertical は V ブランク期間

になります。 

 

Picture Setting で設定される Width は有効画素幅で、Height は有効画素高さになります。 

 

SyncMode Setting で Low Active と設定した場合は、VSYNC、HSYNC 共にブランク期間は Low 状

態となります。 

 
 

High Active と設定した場合は、VSYNC、HSYNC 共にブランク期間は High 状態となります。 

 
 

742 

102 

32 

画像有効領域 

有効画素幅 ：640 ドット 

有効画像高さ；480 ライン 

512 

V ブランク期間(32 ライン) 

H ブランク 

期間 

(102 ｸﾛｯｸ) 

640 

480 



                       SVO システムソフトウェアマニュアル Rev.1.34 

NDC00012 

 

Net Vision Corp. 

 

45 

 

Data Input Timing Setting で Pixel Clock Low Edge と設定した場合は、ピクセルクロックの

立下り時にデータが有効となります。 

 
 

Pixel Clock High Edge と設定した場合は、ピクセルクロックの立上がり時にデータが有効と

なります。 

 
 

Picture Setting で設定される 1 Clock Bit Size で 8 と設定した場合は、1回のピクセルクロ

ックでデータ出力バスのうち、D0-D7 の 8 ビットが有効であることを意味します。 

16 と設定した場合は、1回のピクセルクロックでデータ出力バスのうち、D0-D15 の 16 ビット

が有効であることを意味します。 

 
 

Picture Setting で設定される 1 Color Bit Size で 8 と設定した場合は、1カラー成分が 8ビ

ットであることを意味します。 

10 と設定した場合は、1カラー成分が 10 ビットであることを意味します 

12 と設定した場合は、1カラー成分が 12 ビットであることを意味します 

16 と設定した場合は、1カラー成分が 16 ビットであることを意味します 
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14. SVOview アプリケーション操作方法 
SVOview アプリケーションの概要、操作方法を説明します。 

 

14.1. SVOview とは 

SVOview.exe は SVI 側で長時間録画した FRM、FRMT ファイルを表示、観覧するのみのアプリケ

ーションです。DAT ファイル、256MB 以下の FRM ファイルは SVOGenerator.exe でも表示、観覧

できます。SVOview は SVOGenarator.exe よりデバイス関連のコマンドを削除したもので、

SVOUSB20.dll ファイルは必要ありません。 

 

14.2. アプリケーション（SVOview）の起動 

 

①5.2“アプリケーション、ライブリー関連のインストール”でコピーした SVO-AP フォルダ

内にある“SVOview.exe”を実行します。 

②下図の SVOview の画面が表示されます。表示された SVOview のステータスバーに“Ready”

と表示されていることを確認します。 

 
以上で起動終了です。 
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14.3. アプリケーション（SVOview）の終了 

 

①“File”→“Exit”をクリックするか、画面右上の“×”ボタンをクリックします。 

  
以上でアプリケーションは終了です。 

 

 

14.4. ファイルオプション（解析情報）設定 

 

①“File”→“Option”をクリックするか、ツールバーの アイコンをクリックします。 

②“File Option”ダイアログが表示されるので、これから読み込むデータファイルにあっ

た設定を行います。 

 
③設定が終了したら“OK”ボタンをクリックします。 

 

※ファイルオプションの設定はデータファイルを読み込む前にお願いします。SVOGenarator

でが、読み込んだ後でも変更可能でしたが、SVOview では大容量のファイルを扱うため、変更

後の自動再読み込みは対応していません。 

○ Picture Type 設定 

FRM ファイルのピクチャタイプを指定します。FRM ヘッ

ダーによる自動判別は行いません。UYVY-16bit、

VYUY-16bit、YUY2-16bit はそれぞれ、UYVY、VYUY、YUY2

と同じ扱いになります。 

○ View Play Speed 設定 

View->Play 時のフレーム間のインターバルをミリ秒

単位で設定します。 
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14.5. データファイルの読込み 

 

①“File”→“Open”をクリックするか、ツールバーの アイコンをクリックします。 

②“ファイルを開く”ダイアログが表示されるので、適切なファイルを選択します。 

 
※SVI で作成したファイル以外のファイルを開いた場合、アプリケーションの動作が不安定

になることがあります。その場合は再度アプリケーションを終了し起動しなおしてくださ

い。 

※拡張子が”FRM”または”FRMT”のみ開くことができます。FRM ファイルを指定すると、

その FRM ファイルのみオープンすることになります。FRMT ファイルを指定すると、その FRMT

ファイルに記述されている FRM ファイルをすべてオープンすることになります。 

③File Option の設定を基に、データの解析を行います。終了すると画像を表示します。 

 
※解析が正常に終了するとステータスバーに“Analyze Complete”と表示されます。 

解析が途中で異常終了した場合ステータスバーに“Analyze Incomplete”と表示されます 
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14.6. データ確認 

 

①“View”→“Play”または、ツールバーの アイコンを選択しデータを１フレームずつ

確認します。 

 
②ステータスバーには現在表示中のフレーム番号、画像サイズが出ていますので、再生中に

適宜参照してください。 

③画像データのフレームを飛ばしながら確認したい場合には“View”→“Jump To” 

画像データの色を確認したい場合には“View”→“Color Bar” 

ファイルのヘッダ情報を参照したい場合には“View”→“File Information” 

で確認してください。 

ステータスバーや各ダイアログの詳細は SVOGenerator の Help を参照してください。 
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14.7. SVOview のバージョン確認 

 

①“Help”→“About SVOview...”を選択すると SVOview のバージョンを確認することがで

きます。 

 
②バージョン確認ダイアログボックスが下図の通りです。 

 
③確認が終了したら“OK”ボタンをクリックします。 

※ SVOview.exe ではヘルプファイルを用意していません。 SVOview の各機能は

SVOgenerator.exe と同一であるため、SVOGeneraotr.exe のヘルプをご覧ください。 

 

 


