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1. 概要 

 

本書は、USB 3.0 経由で入力される映像信号を MIPI CSI-2 信号に変換するためのボ

ード「SVO-03-MIPI」専用ソフトウェア「SVOGenerator」のソフトウェアマニュアルです。 

SVO-03-MIPI ボード付属の SVOGenerator (以下本ソフトウェアと表記) は、弊社既存

ボード（SVO-03）付属 SVOGenerator をベースにしており、ユーザインタフェースの多くを

共通化しています。 

なお、本ソフトウェアで既存ボードのコントロールは可能ですが、既存ボード付属の 

SVOGenerator を使用して  SVO-03-MIPI のコントロールはできません。すでに 

SVOGenerator がインストール済みの場合、本ソフトウェアを別にインストールするか、ソ

フトウェアの置き換えが必要です。 

本書は暫定版につき、予告なく仕様が変更される可能性があります。また、製品に未実装の機能についての説明を含みま

す。なお本書には一部に「HDMI 版」についての説明もありますが、「HDMI 版」はオプション機能であり、現在開発中です。 

 

1.1. システム構成図 

システム構成図 

 

 

1.2. 動作環境 

OS   ： Windows7 以降 64bit/32bit 

他   ： 弊社提供アプリケーション、ライブラリ、 

      デバイスドライバー(8.1 は 64bitのみ) 

 

1.3. 必要なソフトウェア 

SVOシステムを動作させるために必要な弊社提供のソフトウェアは以下の通りです。 

 

・SVOGenerator.exe 

  PC に保存された映像ファイルを SVO-03-MIPI / SVO-03 ボードに出力するためのアプリケーションです。 

 

ホスト PC 

Windows 32bit/64bit  

 

 

 

画像表示／ 

出力用アプリ 

 SVOGenerator  

 

 

 

SVO 

USB 

3.0 

ドライバ 

USB3.0 
SVO board 

<SVO-03-MIPI> 

ハードウェア 

ファームウェア  

 

 

 

画像 

出力 

ライブラリ  

ターゲット 

ボード  

MIPI CSI-2 

 1-4 Lanes 

SVOシステム 
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・SVOUSB30.dll 

  SVOシステム専用の USB3.0 デバイスドライバーを使用した SVO映像出力ライブラリです。 

 

・SVOUSB30.sys、SVOUSB30.inf 

  32bit版 SVOシステム専用 USB3.0 デバイスドライバーファイルです。 

 

・SvoU3drv.dll、SvoUdrv.inf 

  64bit版 SVOシステム専用 USB3.0 デバイスドライバーファイルです。 

 

- SVOGenerator終了後、以下のファイルが生成されます。 

 

・SVOGenerator.ini 

  主に File-Option ダイアログの情報を保存します。 

 

・SVOGenerator.svo 

  主に Device-Setting ダイアログの情報を保存します。 

 

 

2. インストール 

 

SVO-03-MIPI ハードウェアに同梱されているソフトウェア CD-ROM に必要なソフトウェアが格納されています。この CD-

ROM の内容は下表の通りです。 

 

フォルダ 内容 

\ readme.txt、version.txtを格納しています 

\SVO-AP_x86 アプリケーション、ライブラリ関連を格納しています 

\SVO-AP_x64 上記 64bit版を格納しています 

\Driver_x86 SVO専用 USB3.0 デバイスドライバー関連を格納しています 

\Driver_x64 上記 64bit版を格納しています 

\DOC 各種ドキュメントを格納しています 

\映像出力ライブラリ 映像出力ライブラリファイルを格納しています 

\Tool フレームファイルコンバーターユーティリティーを格納しています 

 

2.1. SVO専用 USB3.0デバイスドライバのインストール 

 

1. SVO-03-MIPI ボードと PC の USB3.0 ポート を USB3.0 ケーブルで接続します。 

 

2. デバイスマネージャを起動し、「ほかのデバイス」 以下の 「SVO-09」をダブルクリックします。 

 

 

 

3. 「SVO-09 のプロパティ」ダイアログが表示されますので、「ドライバーの更新」ボタンをクリックします。 
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4. 「コンピューターを参照してドライバーソフトウェアを検索します」をクリックします。 
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5. CD-ROM を CD ドライブに挿入し、「参照」ボタンにて「Driver_SVO\Driver_x64」フォルダ（64bit OS の場合）を選択し、

「次へ」をクリックします。 

 

6. しばらくすると、インストールが終了します。 

 

 

7. 正常にインストールが終了すると、SVO クラスに「SVO-09」が登録されます。 

 

 

- 32bit OS へのドライバインストールは CD-ROM の SVO_Driver\Driver_x86 以下に格納のデバイスドライバをご使用く

ださい。 
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2.2. アプリケーション、ライブラリ関連のインストール 

 

CD-ROM 内の 「SVO-AP_x64」フォルダをハードディスクの任意の場所へコピーしてください。 

念のためコピー先の「SVO-AP_x64」フォルダの属性が読み書き可能になっているのを確認して下さい。 

 

- Windows7 32bit 版は CD-ROMの「SVO-AP_x86」フォルダに格納されています。使用方法は同一です。 

 

3. アンインストール 
 

3.1. デバイスドライバのアンインストール 

SVO 専用デバイスドライバのアンインストールが必要な場合、デバイスマネージャにて、SVO-09 を削除してください。下図

のように「このデバイスのドライバー ソフトウェアを削除する」にチェックをしてください。 

 

3.2. アプリケーション、ライブラリ関連のアンインストール 

コピーした SVO-AP_x64 または SVO-AP_x86 フォルダを削除してください。 

 

4. DIP スイッチ設定 

1 台の PC に複数の SVO ボードが接続される場合、各ボードの DIP SW (SW2) の状態により ID を割り振り、識別するこ

とができます。DIP SW の状態と ID の割り当て一覧は、以下の通りです。 

 

ID #8 #7 #6 #5 #4 #3 #2 #1 Device-Select

表示 

About Dialog 表

示 

0 OFF OFF OFF OFF OFF OFF OFF OFF 0000 0000xxxx 

1 OFF OFF OFF OFF ON OFF OFF OFF 0001 0001xxxx 

2 OFF OFF OFF ON OFF OFF OFF OFF 0002 0002xxxx 

3 OFF OFF OFF ON ON OFF OFF OFF 0003 0003xxxx 

4 OFF OFF ON OFF OFF OFF OFF OFF 0004 0004xxxx 

5 OFF OFF ON OFF ON OFF OFF OFF 0005 0005xxxx 

6 OFF OFF ON ON OFF OFF OFF OFF 0006 0006xxxx 

7 OFF OFF ON ON ON OFF OFF OFF 0007 0007xxxx 
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5. アプリケーションの操作方法 
SVOGenerator を使った、基本的なアプリケーションの操作の一連の流れと個別の操作方法を説明します。またアプリ

ケーションの項目の詳細についてはアプリケーションのヘルプも参照してください。 

 

5.1. アプリケーション操作の流れ 

SVO-03-MIPI ボードから映像信号を出力するまでの基本的な流れを下記に示します。各項目の操作方法は 5.2 

以降に示します。 

 

 

USB版                               HDMI版 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

アプリケーション（SVOGenerator）の起動 

ファイルオプション（解析情報）設定 

データファイルの読込み 

データ確認 

SVOボード選択 

出力タイミング等の設定 

映像信号出力開始 

映像信号出力停止 

 

アプリケーション（SVOGenerator）の終了 

 

アプリケーション（SVOGenerator）の起動 

SVOボード選択 

SVOボード設定情報作成 

SVOボードへのデータ送信 

アプリケーション（SVOGenerator）の終了 
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5.2. アプリケーション（SVOGenerator）の起動 

 

① 3.2 「アプリケーション、ライブラリ関連のインストール」でコピーした 「SVO-AP_x??」フォルダ内にある

「SVOGenerator.exe」を実行します。 

② 下図のような「SVOGenerator」画面が表示されます。 

 

 

以上で起動終了です。 

 

 

5.3. ファイルオプション（解析情報）設定 

 

① File -> Option をクリックするか、F12 キーを押下します。 

② File Option ダイアログが表示されるので、これから読み込む映像ファイルに応じた設定を行います。 

 

- Picture Type: 映像ファイルのピクセルフォーマットを指定します。 

- RAW bit width: Picture Type = RAW のとき、1 ピクセルあたりの bit 深度を指定します。 
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- ViewPlaySpeed: 「データ確認」時の映像更新インターバルを指定します。 

 出力映像データのフレームレートとは独立です。 

- Raw File Format: Raw ファイル読み込み時のデータフォーマットを指定します。AVI および FRM ファイル読み

込み時、この設定は無視されます。 

③設定が終了したら"OK"ボタンをクリックします。 

- ファイルオプションの設定は必ず映像ファイルを読み込む前に行ってください。 

 

5.4. 映像ファイルの読込み 

 

① File -> Open をクリックするか、ツールバーの アイコンをクリックします。 

② 「ファイルを開く」ダイアログが表示されるので、適切なファイルを選択します。 

 

拡張子 .frmt, .frm, .avi, .raw, .bw ファイルに対応します。。 

AVI ファイルを開く場合、FourCC が"YUY2","UYVY","DIB "いずれかである必要があります。 

③ File Option の設定をもとに、データの解析を行います。終了すると画像を表示します。 

 

- 解析が正常に終了するとステータスバーに"Analyze Complete"と表示されます。 

解析が途中で異常終了した場合ステータスバーに"Analyze Incomplete"と表示されます 

- YUV系で色が不正な場合は File-Option にて並びを変更してみてください。 
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5.5. 映像データの確認 

 

① View -> Play または、ツールバーの アイコンを選択しデータを 1 フレームずつ確認します。 

  

② ステータスバーには現在表示中のフレーム番号、画像サイズを表示します。 

③ 画像データのフレームを飛ばしながら確認したい場合には"View"->"Jump To" 

画像データの色を確認したい場合には"View"->"Color Bar" 

ファイルのヘッダ情報を参照したい場合には"View"->"File Information" 

で確認してください。 

ステータスバーや各ダイアログの詳細は SVOGeneratorの Helpを参照してください。 

 

5.6. SVOボードの選択 

 

① Device -> Select をクリックするか、キーボードの F3 キーまたはツールバーの を押します。 
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② 「Device Select」ダイアログが表示されます。ドロップダウンリストに現在 USBポートに接続されている SVO ボ

ードの識別 ID が表示されますので、制御を行うボードの ID を選択します 

 

③ 「Select」ボタンを押します。 

 

 

 

5.7. 出力タイミング等の設定 

① Device -> Setting をクリックするか、キーボードの F4 キー、ツールバーの アイコンをクリックします。 
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② 「Device Setting」ダイアログが表示されます。各設定項目を設定します。設定項目については、"6. Device Setting ダ

イアログ" を参照して下さい。 

 

- 「Device Select」ダイアログで選択されたボードを認識して、表示する設定項目を変更しています。「Device Setting」ダイ

アログを表示する前に、「Device Select」ダイアログよりボードの選択を行ってください。 

- 「SAVE SET」ボタンを押すと、現在の設定内容を任意のファイルへ保存します。 

- 「RESTORE SET」ボタンを押すと、「SAVE SET」により保存した設定内容を読み込みます。 

 

③ 設定が終了したら「Apply」ボタンを押します。 

 

以上で設定は終了です。 
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5.8. 映像信号の出力コントロール 

① Device -> Control またはキーボードの F6 キー、ツールバーの アイコンをクリックします。 

  

 

② 「Device Control」ダイアログが開くと、最初にボード上の DRAM に対し映像フレームが転送されます。「Play」

ボタンが有効になると転送可能状態になります。 

 

- Play cycle: チェックされている場合、繰り返し映像出力を行います。 

- Play mode: チェックされている場合、PC 内の AVI ファイルの全体を順次 ボード上 DRAM のフレームバッファ

を介して出力されます。チェックされていない場合、AVI ファイルの先頭のみボード上 DRAM に転送して、DRAM 

の内容を繰り返し出力します。 

- Image sync: チェックされている場合、出力と同時に SVOGenerator 側画面を約 1 秒毎に更新します。 

 画面には「最後に SVO ボードに送出したフレーム」の画像が表示されます。SVO ボードにはフレームバッファ

を持っているため、現在送出中のフレームの画像とはタイムラグが存在します。 

 

- External Trigger: 外部同期機能を有効とします。外部同期信号のフォーマットは Device Setting ダイアログで設

定します。 

- External V/HSync: 通常はチェックを外してください。 

- External PCLK: 通常はチェックを外してください。 



SVO-03-MIPI ソフトウェアマニュアル (NDC00071) 

1.5 

 13 

- Trigger Out: 複数 ch 同時出力時に使用する映像出力トリガ信号を出力します。通常はチェックを外してくださ

い。 

 

③ 「Play」ボタンを押すと、映像出力が開始されます。 

 

④ 映像出力が始まると「Play」ボタンが無効状態になり、「Current Position」が「Total Output Frames」までカウント

アップされます。 

映像出力中に「Stop」ボタンを押すと、映像出力を停止することができます。ファイル全てを転送し終わると、

再び「Play」ボタンが有効状態になります。 

 

 

6. Device Setting ダイアログ (SVO-03-MIPI 版) 

 

 

- 「SAVE SET」ボタンを押すと、現在の設定内容を任意のファイルへ保存します。 

- 「RESTORE SET」ボタンを押すと、「SAVE SET」により保存した設定内容を読み込みます。 

- 「Easy Timing Generator...」ボタンを押すと、「Video Timing Setting」の設定項目を簡単に設定するためのダイアログが

開きます。 

- 「Apply」ボタンを押すと、現在の設定内容がボードに送信されます。 

 

 Board Select ダイアログで SVO-03-MIPI ボードが選択された状態で「Device Setting」メニューをクリックすると、上記のよ
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うな Device Setting ダイアログが表示されます。このダイアログの設定により、映像信号のタイミングおよびフォーマットを設

定します。SVO-03-MIPI の出力タイミングを適切に設定するためには、ボードの映像出力構成をある程度理解する必要があ

ります。 

 下図のように、SVO-03-MIPI ボードは FPGA 内部に 2 段の映像出力ブロックを持ちます。1 段目のビデオ信号生成器で 

32bit パラレル映像信号を生成し、2 段目の MIPI 信号コンバータでパラレル映像信号からシリアル信号へのシリアライズを

行います。シリアル信号は MIPI D-PHY を経由して、MIPI CSI-2 信号としてボード外部に出力されます。 

 MIPI CSI-2 では Short Packet と呼ばれるパケットにより映像信号のライン、フレームを判別します。映像を構成するため

に最低限必要な Short Packet は「FS(Frame Start)」「FE(Frame End)」の 2 種類で、パラレル映像信号の VSync に対応する

ものです。そこで本ボードでは、パラレル信号の VSync の変化するタイミングで「FS」「FE」を出力しています。各ラインのデー

タは映像信号の 1 ラインごとに、各ラインが終了するタイミングで出力されます。 

 

 パラレル信号と MIPI CSI-2 信号のタイミングの関係を下図に示します。下図において (1) Parallel Signal のタイミングチャ

ートに示したタイミングパラメータには、Device Setting ダイアログにある同名の設定項目が反映されます。パラレル信号のタ

イミングパラメータの名前および機能はパラレル版 SVO-03 ボードの設定項目と同じです。(2) MIPI CSI-2 Signal は出力デ

ータとなる MIPI CSI-2 信号を示し、(1)(2) 間の矢印がタイミングの対応を示します。例えば、FE (Frame End) パケットはパラ

レルの VS (VSync) 信号の立下りで出力されることを示しています。 
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- FE: Frame End, FS: Frame Start, PH: Packet Header, PF: Packet Footer 

- FE/FS のみ出力する場合、DE 信号、HS 信号は必ずしも分ける必要はなく、同一タイミングとすることも可能です。 

 

 

6.1. Device Setting ダイアログの設定項目 

Video Timing Setting の設定項目では、パラレル信号のタイミングを設定します。MIPI 出力タイミングの設定は、すべてこ

れらのパラレル信号のタイミング調整によって行います。 

設定項目 説明 単位 

VSSP (上図参照) PCLK 

VSPP (上図参照) PCLK 

HSSP (上図参照) PCLK 

HSPP (上図参照) PCLK 

HSIP (上図参照) PCLK 

HSPR HSync 信号の繰り返し回数を指定します。  

DESP (上図参照) PCLK 

DEPP (上図参照) 

ピクセルフォーマットが YUV4:2:2 8bit, Raw10, Raw12 の場合、入力映像ファイル

の幅の 1/2 を指定する必要があります。 

ピクセルフォーマットが RGB888, Raw20 の場合、入力映像ファイルの幅と等しい

値を指定する必要があります。 

PCLK 

DEIP (上図参照) PCLK 
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DEPR Data Enable 信号の繰り返し回数を指定します。 

入力映像ファイルの高さと同じ値を指定する必要があります。 

 

Parallel PCLK パラレル信号のピクセルクロックを指定します。 MHz 

Byte Swap 8bit 単位のバイトスワップを指定します。 

通常は [D3,D2,D1,D0]を指定してください。 

YUY2 形式の .avi ファイルを読み込み YUV4:2:2 で出力する場合、 

[D2,D3,D0,D1] を指定してください。 

 

- Parallel PCLK に設定するクロック数をリストボックス内の設定値以外から設定したい場合、別途お問い合わせください。 

- 誤ったタイミングを設定した場合、映像信号の出力が行われないことがあります。 

- タイミング詳細については、SVO-03-MIPI 基板のハードウェア仕様書も参照してください。 

 

HS** = DE** としたときの、パラレル信号の出力イメージを上図に示します。 

 

 MIPI CSI-2 Setting の設定項目では、MIPI CSI-2 信号のパラメータおよびピクセルフォーマットを設定します。 

設定項目 説明 単位 

Pixel Format ピクセルフォーマットを指定します。  

Data Rate レーン当たりのビットレートを指定します。 

ボードのスペックを満たす値を指定してください。 

Mbps 

Lane Count レーン数を指定します。 Lane 

Continuous Clock チェックすると、CLK レーンが常時 HS (Continuous Clock)で出力されます。 

Continuous Clock しか受け付けないターゲットデバイスで使用する場合、チェック

を入れてください。 

ターゲットデバイスによっては対応しないので、必要ない場合はチェックを外してく

ださい。 

 

- Video Timing Setting で設定したデータレートよりも MIPI CSI-2 Setting で設定するデータレート (Lane Count x Data Rate) 
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を大きく設定してください。 

 

「Easy Timing Generator...」ボタンを押すと、「Video Timing Setting」の設定項目を簡単に設定するためのダイアログ（MIPI 

Easy Timing Generator ダイアログ）が開きます。 

 

 External Sync Mode の設定項目では、外部同期信号のフォーマットを設定します。外部同期機能を使用しない場合、この設

定は無視されます。外部同期は Mode が「Invalid」以外かつ、Device Control 画面の「External Trigger」にチェックが入ってい

るとき、有効化されます。 

設定項目 説明 

Mode 外部同期モードを設定します。 

Invalid: 外部同期機能は無効化されます。 

Start: 出力開始タイミングを外部信号に同期化します。 

Frame: 各フレームの出力を外部信号に同期化します。 

Start/Stop: 出力開始/終了タイミングを外部信号に同期化します。 

Polarity 同期信号の極性を指定します。 

H Level: 外部同期信号が H レベルのとき、映像フレーム出力が有効化されます。 

L Level: 外部同期信号が L レベルのとき、映像フレーム出力が有効化されます。 

Pos Edge: 外部同期信号の L->H エッジで映像フレーム出力が有効化されます。 

Neg Edge: 外部同期信号が H -> L エッジで映像フレーム出力が有効化されます。 

Stretch 通常「None」を指定してください。 

 

6.2. Easy Timing Generator ダイアログの設定項目 

 

 MIPI Easy Timing Generator ダイアログの OK ボタンを押すと、入力された映像解像度、ピクセルフォーマット、フレームレ

ートをもとにパラレル信号のタイミングを自動生成して、もとのダイアログの項目に設定します。 

 

設定項目 説明 

Video Resolution 解像度を指定します。 

入力映像ファイルの解像度と等しくなるように設定してください。 

Pixel Format ピクセルフォーマットを指定します。 
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Frame Rate 出力フレームレートを指定します。 

入力映像ファイルのフレームレートとは独立に指定できます。 

V-Blank ブランキング期間（MIPI の場合、FE - FS の期間）をパラレル信号の PCK （148.5MHz）単位

で設定します。 

 

 

6.3. タイミング設定例 (解像度、フレームレートから設定する場合） 

- 解像度: 1920x1080 

- フレームレート: 30FPS 

- ピクセルフォーマット: YUV4:2:2 8bit (UYVY) 

- MIPI データレート: 800Mbps / Lane 

- MIPI データレーン数: 4 Lane 

 

1. 「Easy Timing Generator...」ボタンをクリックして、ダイアログを呼び出します。 
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2. 下記のように入力して、「OK」ボタンを押します。 

 

「Video Timing Setting」には自動的に値が設定されま

す。 

 

3. 「MIPI CSI-2 Setting」部分の設定を行います。 

設定値は右記の通りです。 

 

4. 「Apply」ボタンをクリックすると、設定値が FPGA に

セットされます。 

 

 

 

 

 

6.4. タイミング設定例（タイミングチャートから設定する場合） 

 

- 解像度: 1920x1080 

- フレームレート: 30FPS 

- ピクセルフォーマット: YUV4:2:2 8bit (UYVY) 

- MIPI データレート: 800Mbps / Lane 

- MIPI データレーン数: 4 Lane 
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1. 「Video Timing Setting」部分の値を計算してセットします。 

VSSP = 96800 (2200x44) 

VSPP = 2378200 (2200x(1080+1)) 

 

HSSP = 98320 (VSSP + 2200+280-(1920/2)) 

HSPP = 960 (1920/2) 

HSIP = 1240 (280+(1920/2) 

HSPR = 1080 

 

DESP = HSSP 

DEPP = DSPP 

DEIP = HSIP 

DEPR = HSPR 

 

 

2. 「MIPI CSI-2 Setting」部分の設定を行います。 

 

3. 「Apply」ボタンをクリックすると、設定値が FPGA にセットされます。 

 

7. ボードのアップデート 

SVO-03-MIPI ボードは USB 経由で ファームウェア、FPGA コンフィギュレーションのアップデートが可能です。アップデ

ート手順は下記の通りです。 

1. DIP SW (SW1) の 7 番が ON、8 番が OFF の状態で SVO-03-MIPI ボードを PC に接続してください。 

2. USB モードとは異なるドライバで動作するので、初回起動時はデバイスマネージャから手動でドライバをインストール

してください。 

1. 「ほかのデバイス」->「SVM-03U」を右クリックして、「ドライバー ソフトウェアの更新」をクリック 

2. 「コンピューターを参照してドライバーソフトウェアを検索します」をクリック 
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3. ドライバのフォルダ（Driver_SVI または Driver_SVM）を選択して、「次へ」をクリック 

3. 「SVMCtl」を起動して、「SVM Setting...」をクリックしてください。 

4. 「Multi Update...」または「FPGA Update...」を選択して、アップデートイメージを選択すると、アップデートが開始されます。 

 FPGA のみアップデートする場合は「FPGA Update...」、全領域をアップデートする場合は「Multi Update...」を選択しま

す。アップデート時にどちらを選択するかは、アップデートイメージの説明書に従ってください。 

 

5. アップデートには数分間かかります。この間 USB ケーブルを抜いたり、PC の電源を切らないでください。 

6. アップデート終了のメッセージが出たら、「SVMCtl」を終了して USB ケーブルを抜いてください。 

7. DIP SW を元に戻して、アップデート完了です。 

 

 

8. FRM形式のデータフォーマット 
 

SVOシステムで対応する画像データは SVIシステムで作成された FRM 形式と一般的な AVI形式があります。 

FRM 形式はカメラモジュールまたはイメージセンサから出力されたデータをフレームごとに 40 バイトのヘッダが付加され

たもので、フレームの前にヘッダが記録されます。 

データ部はカメラから出力されたままを記録します。但しフレーム部のバイト数は 64 で割り切れるようパディングデータが

付加されています。 

以下に、FRM 形式の画像ファイルフォーマットの詳細を示します。 
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画像の階調が 10ビット、12ビット、16 ビットのバイト並びはビックエンディアンとなります。 

 

FRM ファイルは最大 2GB の制限がありますので、それ以上になる場合は複数の FRM ファイルとし、管理するために

FRMT ファイルを使用します。FRMT ファイルはテキスト形式で FRM ファイル名を絶対パス付で記録したものです。 

 

 例）Cドライブ直下の Dataというフォルダに FRMファイルが 2つある場合 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

FRMT ファイルはテキスト形式ですので、Notepad などのテキストエディターなどで編集ができます。上記ように

FRM ファイルが 2 つしかなくても以下のように同じ FRM ファイルを複数行にすることで長時間の出力が可能となり

ます。出力は FRMTファイルの記述通りの順番で出力されます。 

 

 例）Cドライブ直下の Dataというフォルダに FRMファイルが 2つあって、同じファイルを 
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   3回コピーして長時間出力に対応する場合 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 
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