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改訂履歴 
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1.0 2018/04/04 Preliminary 
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山田 

1.1 2018/07/18 外部同期の説明を追加 

アップデート方法の記述を修正 

Raw10/Raw12 グレースケール表示機能を追加 

山田 

1.2 2018/11/12 Raw ファイル入力の対応 山田 

1.3 2018/12/27 6 章の内容を追記 

タイミング設定例を追加 

マニュアル名を「SVO-MIPI」から「SVO-03-MIPI」に変更 

山田 

1.4 2019/04/11 SVOUSB30.dllについての説明を一部変更 薄葉 

1.5 2019/06/14 Byte Swap 機能、Easy Timing Generator の V-Blank 設定の追加 山田 

1.6 2022/09/12 SVOGenerator と NVFilePlayer の位置づけについての記述を追加 

SVO-03-MIPI のソフトマニュアルから SV シリーズのソフトマニュアル

に資料の位置づけと説明文を変更 

資料のタイトルを「SVOGenerator ソフトウェアマニュアル」に変更 

DIP スイッチ設定を修正 

「リストを作って連続再生する」を追加 

山田 

1.7 2023/12/01 「4.3. ファイルオプション（解析情報）設定」を変更 柏木 

1.8 2024/05/30 7章としてアプリケーション・エラーメッセージ一覧を追加しました。 今野 
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1. 概要 

 

本書は、NetVision SV シリーズの映像出力（ビデオジェネレータ）ボード専用ソフトウェア

「SVOGenerator」のソフトウェアマニュアルです。 

SVシリーズのうち「SVO-03-MIPI」以降のボードに付属されている SVOGenerator (以下

本ソフトウェアと表記) は、弊社既存ボード（SVO-03）付属 SVOGenerator をベースにして

おり、ユーザインタフェースの多くを共通化しています。 

 

本 CD-ROM(または CD イメージ) に付属の SVOGenerator で SVO-03 以降のボー

ドのコントロールは可能ですが、SVO-03 ボード付属の SVOGenerator は SVO-03-MIPI 

に対応していないバージョンが存在します。SVO-03 ボードをすでに使用中のお客様で、SVOGenerator がインストール済み

の場合でも、本 CD-ROM に付属のソフトウェアを使用してください。 

バージョンアップなどにより、本書の内容は予告なく仕様が変更される可能性があります。 

 

- 2022 年より、SVO-03、SVO-03-MIPI やそれ以降に開発した SV シリーズに対応したソフトとして、SVOGenerator に加

えて「NVFilePlayer」も付属しています。「NVFilePlayer」は「SVOGenerator」 と比較して、再生機能の強化や RAW の表示対

応、再生範囲を指定した出力などいろいろな機能を追加しています。「NVFilePlayer」の詳細は別資料（NVFilePlayer ソフトウ

ェアマニュアル）を参照してください。 

 

1.1. システム構成図 

システム構成図 

 

 

1.2. 動作環境 

OS   ： Windows8.1 以降 64bit 

他   ： 弊社提供アプリケーション、ライブラリ、 

      デバイスドライバー(8.1 は 64bitのみ) 

 

ホスト PC 

Windows 32bit/64bit  

 

 

 

画像表示／ 

出力用アプリ 

 SVOGenerator  

 

 

 

SVO 

USB 

3.0 

ドライバ 

USB3.0 
SVO board 

<SVO-03-MIPI> 

ハードウェア 

ファームウェア  

 

 

 

画像 

出力 

ライブラリ  

ターゲット 

ボード  

MIPI CSI-2 

 1-4 Lanes 

SVOシステム 
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1.3. 必要なソフトウェア 

SVOGenerator を使って SV シリーズを動作させるために必要な弊社提供のソフトウェアは以下の通りです。 

 

・SVOGenerator.exe 

  PC に保存された映像ファイルを SV シリーズの映像出力ボードに出力するためのアプリケーションです。 

 

・TimingGen*.exe 

  SV シリーズの映像タイミングデータを作成するためのアプリケーションです。SVOGenerator から呼び出されます。 

 

・SVOUSB30.dll 

  SVOシステム専用の USB3.0 デバイスドライバーを使用した SVO映像出力ライブラリです。 

 

・SvoU3drv.dll、SvoUdrv.inf 

  64bit版 SVOシステム専用 USB3.0 デバイスドライバーファイルです。 

 

- SVOGenerator終了後、以下のファイルが生成されます。 

 

・SVOGenerator.ini 

  主に File-Option ダイアログの情報を保存します。 

 

・SVOGenerator.svo 

  主に Device-Setting ダイアログの情報を保存します。 

 

 

2. インストール 

 

弊社ウェブページからダウンロードできる「CDイメージファイル」に必要なソフトウェアが格納されています。お使いの PCの

任意のフォルダに展開して使用してください。ただし、.exe ファイルのフォルダパスに日本語が含まれることは推奨しません。 

 

- 64bit OS を使用している場合は、64bit 版ソフトウェア、ドライバを使用してください。 

 

2.1. SVO専用 USB3.0デバイスドライバのインストール 

 

1. SV シリーズボードと PC の USB3.0 ポート を USB3.0 ケーブルで接続します。 

 

2. デバイスマネージャを起動し、「ほかのデバイス」 以下の 「SVO-09」をダブルクリックします。 

- ボードによってデバイス名は異なります。 

 

 

3. 「SVO-09 のプロパティ」ダイアログが表示されますので、「ドライバーの更新」ボタンをクリックします。 
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4. 「コンピューターを参照してドライバーソフトウェアを検索します」をクリックします。 
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5. CD-ROM を CD ドライブに挿入し、「参照」ボタンにて「Driver_SVO\Driver_x64」フォルダ（64bit OS の場合）を選択し、

「次へ」をクリックします。 

 

6. しばらくすると、インストールが終了します。 

 

 

7. 正常にインストールが終了すると、SVO クラスに「SVO-09」が登録されます。 
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3. DIP スイッチ設定 

1 台の PC に複数の SVO ボードが接続される場合、各ボードの DIP SW (SW2) の状態により ID を割り振り、識別するこ

とができます。DIP SW の状態と ID の割り当て一覧は以下の通りです。 (0: OFF, 1: ON) 

 

ID 1 2 3 4 5 6 7 8 Device-Select

表示 

About Dialog 表

示 

0 0   0 0 0   0000 0000xxxx 

1 0   1 0 0   0001 0001xxxx 

2 0   0 1 0   0002 0002xxxx 

3 0   1 1 0   0003 0003xxxx 

4 0   0 0 1   0004 0004xxxx 

5 0   1 0 1   0005 0005xxxx 

6 0   0 1 1   0006 0006xxxx 

7 0   1 1 1   0007 0007xxxx 

8 1   0 0 0   0008 0008xxxx 

9 1   1 0 0   0009 0009xxxx 

10 1   0 1 0   0010 0010xxxx 

11 1   1 1 0   0011 0011xxxx 

12 1   0 0 1   0012 0012xxxx 

13 1   1 0 1   0013 0013xxxx 

14 1   0 1 1   0014 0014xxxx 

15 1   1 1 1   0015 0015xxxx 

 

 

 

 

4. アプリケーションの操作方法 
SVOGenerator を使った、基本的なアプリケーションの操作の一連の流れと個別の操作方法を説明します。またアプリ

ケーションの項目の詳細についてはアプリケーションのヘルプも参照してください。 

 

4.1. アプリケーション操作の流れ 

SV シリーズボードから映像信号を出力するまでの基本的な流れを下記に示します。各項目の操作方法は 5.2 以降

に示します。 

 

 

USB版                               HDMI版 

 

 

 

 

 

 

 

 

 

 

アプリケーション（SVOGenerator）の起動 

ファイルオプション（解析情報）設定 

データファイルの読込み 

アプリケーション（SVOGenerator）の起動 
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4.2. アプリケーション（SVOGenerator）の起動 

 

① 3.2 「アプリケーション、ライブラリ関連のインストール」でコピーした 「SVO-AP_x??」フォルダ内にある

「SVOGenerator.exe」を実行します。 

② 下図のような「SVOGenerator」画面が表示されます。 

データ確認 

SVO ボード選択 

出力タイミング等の設定 

映像信号出力開始 

映像信号出力停止 

 

アプリケーション（SVOGenerator）の終了 

 

SVO ボード選択 

SVO ボード設定情報作成 

SVO ボードへのデータ送信 

アプリケーション（SVOGenerator）の終了 
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以上で起動終了です。 

 

 

4.3. ファイルオプション（解析情報）設定 

 

① File -> Option をクリックするか、F12 キーを押下します。 

② File Option ダイアログが表示されるので、これから読み込む映像ファイルに応じた設定を行います。 

 

- Picture Type: 映像ファイルのピクセルフォーマットを指定します。 

- RAW bit width: Picture Type = RAW のとき、1 ピクセルあたりの bit 深度を指定します。 

- ViewPlaySpeed: 「データ確認」時の映像更新インターバルを指定します。 

 出力映像データのフレームレートとは独立です。 

- Raw File Format: Raw ファイル読み込み時のデータフォーマットを指定します。AVI および FRM ファイル読み

込み時、この設定は無視されます。Header Offsetは映像ファイルの先頭のヘッダーをスキップします。 

③設定が終了したら"OK"ボタンをクリックします。 

- ファイルオプションの設定は必ず映像ファイルを読み込む前に行ってください。 
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4.4. 映像ファイルの読込み 

 

① File -> Open をクリックするか、ツールバーの アイコンをクリックします。 

② 「ファイルを開く」ダイアログが表示されるので、適切なファイルを選択します。 

 

拡張子 .frmt, .frm, .avi, .raw, .bw ファイルに対応します。。 

AVI ファイルを開く場合、FourCC が"YUY2","UYVY","DIB "いずれかである必要があります。 

③ File Option の設定をもとに、データの解析を行います。終了すると画像を表示します。 

 

- 解析が正常に終了するとステータスバーに"Analyze Complete"と表示されます。 

解析が途中で異常終了した場合ステータスバーに"Analyze Incomplete"と表示されます 

- YUV 系で色が不正な場合は File-Option にて並びを変更してみてください。 

 

4.5. 映像データの確認 
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① View -> Play または、ツールバーの アイコンを選択しデータを 1 フレームずつ確認します。 

  

② ステータスバーには現在表示中のフレーム番号、画像サイズを表示します。 

③ 画像データのフレームを飛ばしながら確認したい場合には"View"->"Jump To" 

画像データの色を確認したい場合には"View"->"Color Bar" 

ファイルのヘッダ情報を参照したい場合には"View"->"File Information" 

で確認してください。 

ステータスバーや各ダイアログの詳細は SVOGeneratorの Helpを参照してください。 

 

4.6. SVOボードの選択 

 

① Device -> Select をクリックするか、キーボードの F3 キーまたはツールバーの を押します。 

  

 



SVO-03-MIPI ソフトウェアマニュアル (NDC00071) 

1.7 

 10 

② 「Device Select」ダイアログが表示されます。ドロップダウンリストに現在 USBポートに接続されている SVO ボ

ードの識別 ID が表示されますので、制御を行うボードの ID を選択します 

 

③ 「Select」ボタンを押します。 

 

 

 

4.7. 出力タイミング等の設定 

① Device -> Setting をクリックするか、キーボードの F4 キー、ツールバーの アイコンをクリックします。 

 

 

 

 

  

② 「Device Setting」ダイアログが表示されます。各設定項目を設定します。設定項目については、"6. Device Setting ダ
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イアログ" を参照して下さい。 

 

- 「Device Select」ダイアログで選択されたボードを認識して、表示する設定項目を変更しています。「Device Setting」ダイ

アログを表示する前に、「Device Select」ダイアログよりボードの選択を行ってください。 

- 「SAVE SET」ボタンを押すと、現在の設定内容を任意のファイルへ保存します。 

- 「RESTORE SET」ボタンを押すと、「SAVE SET」により保存した設定内容を読み込みます。 

 

③ 設定が終了したら「Apply」ボタンを押します。 

 

以上で設定は終了です。 
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4.8. 映像信号の出力コントロール 

① Device -> Control またはキーボードの F6 キー、ツールバーの アイコンをクリックします。 

  

 

② 「Device Control」ダイアログが開くと、最初にボード上の DRAM に対し映像フレームが転送されます。「Play」

ボタンが有効になると転送可能状態になります。 

 

- Play cycle: チェックされている場合、繰り返し映像出力を行います。 

- Play mode: チェックされている場合、PC 内の AVI ファイルの全体を順次 ボード上 DRAM のフレームバッファ

を介して出力されます。チェックされていない場合、AVI ファイルの先頭のみボード上 DRAM に転送して、DRAM 

の内容を繰り返し出力します。 

- Image sync: チェックされている場合、出力と同時に SVOGenerator 側画面を約 1 秒毎に更新します。 

 画面には「最後に SVO ボードに送出したフレーム」の画像が表示されます。SVO ボードにはフレームバッファ

を持っているため、現在送出中のフレームの画像とはタイムラグが存在します。 

 

- External Trigger: 外部同期機能を有効とします。同期モード (FSYNC 同期、Start/Stop 同期など) は Device 

Setting ダイアログで設定されたものが適用されます。 

- External V/HSync: 通常はチェックを外してください。 

- External PCLK: 通常はチェックを外してください。 
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- Trigger Out: 複数 ch 同時出力時に使用する映像出力トリガ信号を出力します。通常はチェックを外してくださ

い。 

 

③ 「Play」ボタンを押すと、映像出力が開始されます。 

 

④ 映像出力が始まると「Play」ボタンが無効状態になり、「Current Position」が「Total Output Frames」までカウント

アップされます。 

映像出力中に「Stop」ボタンを押すと、映像出力を停止することができます。ファイル全てを転送し終わると、

再び「Play」ボタンが有効状態になります。 

 

 

5. Device Setting ダイアログ (SVO-03-MIPI 版) 

各ボードの Device Setting ダイアログの説明は「TimingGen ソフトウェアマニュアル」を参照してください。以下は旧バージ

ョンのマニュアルに掲載されていた、「SVO-03-MIPI」ボード用の Device Setting ダイアログの説明です。 

 

 

- 「SAVE SET」ボタンを押すと、現在の設定内容を任意のファイルへ保存します。 

- 「RESTORE SET」ボタンを押すと、「SAVE SET」により保存した設定内容を読み込みます。 

- 「Easy Timing Generator...」ボタンを押すと、「Video Timing Setting」の設定項目を簡単に設定するためのダイアログが

開きます。 

- 「Apply」ボタンを押すと、現在の設定内容がボードに送信されます。 

 

 Board Select ダイアログで SVO-03-MIPI ボードが選択された状態で「Device Setting」メニューをクリックすると、上記のよ



SVO-03-MIPI ソフトウェアマニュアル (NDC00071) 

1.7 

 14 

うな Device Setting ダイアログが表示されます。このダイアログの設定により、映像信号のタイミングおよびフォーマットを設

定します。SVO-03-MIPI の出力タイミングを適切に設定するためには、ボードの映像出力構成をある程度理解する必要があ

ります。 

 下図のように、SVO-03-MIPI ボードは FPGA 内部に 2 段の映像出力ブロックを持ちます。1 段目のビデオ信号生成器で 

32bit パラレル映像信号を生成し、2 段目の MIPI 信号コンバータでパラレル映像信号からシリアル信号へのシリアライズを

行います。シリアル信号は MIPI D-PHY を経由して、MIPI CSI-2 信号としてボード外部に出力されます。 

 MIPI CSI-2 では Short Packet と呼ばれるパケットにより映像信号のライン、フレームを判別します。映像を構成するため

に最低限必要な Short Packet は「FS(Frame Start)」「FE(Frame End)」の 2 種類で、パラレル映像信号の VSync に対応する

ものです。そこで本ボードでは、パラレル信号の VSync の変化するタイミングで「FS」「FE」を出力しています。各ラインのデー

タは映像信号の 1 ラインごとに、各ラインが終了するタイミングで出力されます。 

 

 パラレル信号と MIPI CSI-2 信号のタイミングの関係を下図に示します。下図において (1) Parallel Signal のタイミングチャ

ートに示したタイミングパラメータには、Device Setting ダイアログにある同名の設定項目が反映されます。パラレル信号のタ

イミングパラメータの名前および機能はパラレル版 SVO-03 ボードの設定項目と同じです。(2) MIPI CSI-2 Signal は出力デ

ータとなる MIPI CSI-2 信号を示し、(1)(2) 間の矢印がタイミングの対応を示します。例えば、FE (Frame End) パケットはパラ

レルの VS (VSync) 信号の立下りで出力されることを示しています。 
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- FE: Frame End, FS: Frame Start, PH: Packet Header, PF: Packet Footer 

- FE/FS のみ出力する場合、DE 信号、HS 信号は必ずしも分ける必要はなく、同一タイミングとすることも可能です。 

 

 

5.1. Device Setting ダイアログの設定項目 

Video Timing Setting の設定項目では、パラレル信号のタイミングを設定します。MIPI 出力タイミングの設定は、すべてこ

れらのパラレル信号のタイミング調整によって行います。 

設定項目 説明 単位 

VSSP (上図参照) PCLK 

VSPP (上図参照) PCLK 

HSSP (上図参照) PCLK 

HSPP (上図参照) PCLK 

HSIP (上図参照) PCLK 

HSPR HSync 信号の繰り返し回数を指定します。  

DESP (上図参照) PCLK 

DEPP (上図参照) 

ピクセルフォーマットが YUV4:2:2 8bit, Raw10, Raw12 の場合、入力映像ファイル

の幅の 1/2 を指定する必要があります。 

ピクセルフォーマットが RGB888, Raw20 の場合、入力映像ファイルの幅と等しい

値を指定する必要があります。 

PCLK 

DEIP (上図参照) PCLK 
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DEPR Data Enable 信号の繰り返し回数を指定します。 

入力映像ファイルの高さと同じ値を指定する必要があります。 

 

Parallel PCLK パラレル信号のピクセルクロックを指定します。 MHz 

Byte Swap 8bit 単位のバイトスワップを指定します。 

通常は [D3,D2,D1,D0]を指定してください。 

YUY2 形式の .avi ファイルを読み込み YUV4:2:2 で出力する場合、 

[D2,D3,D0,D1] を指定してください。 

 

- Parallel PCLK に設定するクロック数をリストボックス内の設定値以外から設定したい場合、別途お問い合わせください。 

- 誤ったタイミングを設定した場合、映像信号の出力が行われないことがあります。 

- タイミング詳細については、SVO-03-MIPI 基板のハードウェア仕様書も参照してください。 

 

HS** = DE** としたときの、パラレル信号の出力イメージを上図に示します。 

 

 MIPI CSI-2 Setting の設定項目では、MIPI CSI-2 信号のパラメータおよびピクセルフォーマットを設定します。 

設定項目 説明 単位 

Pixel Format ピクセルフォーマットを指定します。  

Data Rate レーン当たりのビットレートを指定します。 

ボードのスペックを満たす値を指定してください。 

Mbps 

Lane Count レーン数を指定します。 Lane 

Continuous Clock チェックすると、CLK レーンが常時 HS (Continuous Clock)で出力されます。 

Continuous Clock しか受け付けないターゲットデバイスで使用する場合、チェック

を入れてください。 

ターゲットデバイスによっては対応しないので、必要ない場合はチェックを外してく

ださい。 

 

- Video Timing Setting で設定したデータレートよりも MIPI CSI-2 Setting で設定するデータレート (Lane Count x Data Rate) 
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を大きく設定してください。 

 

「Easy Timing Generator...」ボタンを押すと、「Video Timing Setting」の設定項目を簡単に設定するためのダイアログ（MIPI 

Easy Timing Generator ダイアログ）が開きます。 

 

 External Sync Mode の設定項目では、外部同期信号のフォーマットを設定します。外部同期機能を使用しない場合、この設

定は無視されます。外部同期は Mode が「Invalid」以外かつ、Device Control 画面の「External Trigger」にチェックが入ってい

るとき、有効化されます。 

設定項目 説明 

Mode 外部同期モードを設定します。 

Invalid: 外部同期機能は無効化されます。 

Start: 出力開始タイミングを外部信号に同期化します。 

Frame: 各フレームの出力を外部信号に同期化します。 

Start/Stop: 出力開始/終了タイミングを外部信号に同期化します。 

Polarity 同期信号の極性を指定します。 

H Level: 外部同期信号が H レベルのとき、映像フレーム出力が有効化されます。 

L Level: 外部同期信号が L レベルのとき、映像フレーム出力が有効化されます。 

Pos Edge: 外部同期信号の L->H エッジで映像フレーム出力が有効化されます。 

Neg Edge: 外部同期信号が H -> L エッジで映像フレーム出力が有効化されます。 

Stretch 通常「None」を指定してください。 

 

5.2. Easy Timing Generator ダイアログの設定項目 

 

 MIPI Easy Timing Generator ダイアログの OK ボタンを押すと、入力された映像解像度、ピクセルフォーマット、フレームレ

ートをもとにパラレル信号のタイミングを自動生成して、もとのダイアログの項目に設定します。 

 

設定項目 説明 

Video Resolution 解像度を指定します。 

入力映像ファイルの解像度と等しくなるように設定してください。 

Pixel Format ピクセルフォーマットを指定します。 
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Frame Rate 出力フレームレートを指定します。 

入力映像ファイルのフレームレートとは独立に指定できます。 

V-Blank ブランキング期間（MIPI の場合、FE - FS の期間）をパラレル信号の PCK （148.5MHz）単位

で設定します。 

 

 

5.3. タイミング設定例 (解像度、フレームレートから設定する場合） 

- 解像度: 1920x1080 

- フレームレート: 30FPS 

- ピクセルフォーマット: YUV4:2:2 8bit (UYVY) 

- MIPI データレート: 800Mbps / Lane 

- MIPI データレーン数: 4 Lane 

 

1. 「Easy Timing Generator...」ボタンをクリックして、ダイアログを呼び出します。 
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2. 下記のように入力して、「OK」ボタンを押します。 

 

「Video Timing Setting」には自動的に値が設定されま

す。 

 

3. 「MIPI CSI-2 Setting」部分の設定を行います。 

設定値は右記の通りです。 

 

4. 「Apply」ボタンをクリックすると、設定値が FPGA に

セットされます。 

 

 

 

 

 

5.4. タイミング設定例（タイミングチャートから設定する場合） 

 

- 解像度: 1920x1080 

- フレームレート: 30FPS 

- ピクセルフォーマット: YUV4:2:2 8bit (UYVY) 

- MIPI データレート: 800Mbps / Lane 

- MIPI データレーン数: 4 Lane 
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1. 「Video Timing Setting」部分の値を計算してセットします。 

VSSP = 96800 (2200x44) 

VSPP = 2378200 (2200x(1080+1)) 

 

HSSP = 98320 (VSSP + 2200+280-(1920/2)) 

HSPP = 960 (1920/2) 

HSIP = 1240 (280+(1920/2) 

HSPR = 1080 

 

DESP = HSSP 

DEPP = DSPP 

DEIP = HSIP 

DEPR = HSPR 

 

 

2. 「MIPI CSI-2 Setting」部分の設定を行います。 

 

3. 「Apply」ボタンをクリックすると、設定値が FPGA にセットされます。 

 

6. ボードのアップデート 

SV シリーズボードは USB 経由で ファームウェア、FPGA コンフィギュレーションのアップデートが可能です。アップデート

手順は別資料「SVMUpdate ソフトウェアマニュアル」を参照してください。 

 

7. アプリケーション・エラーメッセージ一覧 

7.1. アプリケーションエラー 

項目番号 １ 

エラーメッセージ Device UnOpened 

エラー内容 SVO ボードの Open 処理に失敗 

エラー発生の要因 ・SVO ボードの電源が切れた 

・SVO ボードの異常 

・アプリケーションからボードが認識できない 

対処法 1.一度、アプリケーションを終了し、SVO ボードの電源を OFF にする 

2.ボードの電源を入れ、アプリケーション再立ち上げ 

 

項目番号 ２ 

エラーメッセージ Play Failure（ダイアログの２行目に SVOAPI エラーも表示） 

エラー内容 SVO デバイスからのデータ送出処理に失敗 

エラー発生の要因 ・SVO ボードが処理実行中 

・アプリケーションからボードが認識できない 

対処法 ・SVO ボードの処理が終了するまで待つ 
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上記で対処できない場合は項目番号１の対処法を実行 

 

項目番号 ３ 

エラーメッセージ Shared Memroy UnOpen 

エラー内容 SVO メモリーデータ、画像表示用のメモリー領域が確保できない 

エラー発生の要因 仮想メモリー領域の不足 

対処法 仮想メモリー領域を増やす 

 

項目番号 ４ 

エラーメッセージ File Open Failure 

エラー内容 ファイル Open に失敗 

エラー発生の要因 ・指定されたファイルがーオープンできない。 

・既に別のアプリケーションでオープンされている 

・指定したパスにファイルが見つからない 

対処法 ・ファイルを使用していれば、使用を終了する 

・正しいファイルパスを設定する 

 

項目番号 ５ 

エラーメッセージ Update Incomplete 

エラー内容 FPGA もしくは Firmware のアップデートに失敗 

エラー発生の要因 ・SVO デバイスが Open できない 

・SVO ボードが処理中 

・ファイルデータが不正 

対処法 ・SVO ボードの処理を終了させる 

・ファイルを確認する 

 

項目番号 ６ 

エラーメッセージ Not Data Analyze 

エラー内容 データ解析が終了していない 

エラー発生の要因 ・データを取得していない 

・ファイルのデータが解析できない 

対処法 ・データを取得する 

・ファイルを確認する 

 

項目番号 ７ 

エラーメッセージ Not Selected Device 

エラー内容 SVO ボード未選択 

エラー発生の要因 SVO ボードの選択を行っていない 

対処法 SVO ボードの選択を行う 

 

項目番号 ８ 

エラーメッセージ Not Idol 

エラー内容 SVO ボードが処理実行中 

エラー発生の要因 SVO ボードが処理を実行している 

対処法 SVO ボードの処理が終了するまで待つ。 

項目番号１の対処法を実行する 
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7.2. SVOAPIエラー 

項目番号 ９ 

エラーメッセージ Win32API Error（２行目にエラーの詳細情報） 

エラー内容 Windows の API エラー 

エラー発生の要因 詳細情報による 

対処法 詳細情報による 

 

項目番号 １０ 

エラーメッセージ Connect No Device or Power Off 

エラー内容 USB に SVO ボードがつながれていない。または電源が入っていない 

エラー発生の要因 ・SVO ボードが USB に接続されていない 

・SVO ボードの電源がはいっていない 

対処法 ・デバイスマネージャで SVOUSB20 が認識されていることを確認 

・SVO ボードを接続する 

・SVO ボードの電源を入れる 

 

項目番号 １１ 

エラーメッセージ Device Multi Open 

エラー内容 複数の SVO ボードを Openしようとしている 

エラー発生の要因 ・複数の SVO ボードを Open しようとしている 

・１つの SVO ボードに対して２重に Open しようとしている 

対処法 ・２重 Open していないか確認する 

・複数の SVO ボードを１つのアプリケーションで Open しようとしてい

ないか確認する 

 

項目番号 １２ 

エラーメッセージ Device UnOpened 

エラー内容 SVO ボードが Open していない 

エラー発生の要因 Open していない SVO ボードに対して処理をしようとしている 

対処法 ・SVO ボードを Open する 

・Control ダイアログを閉じて、メニューの Control を選択する。 

 

項目番号 １３ 

エラーメッセージ Parameter Incorrect 

エラー内容 設定パラメータの異常 

エラー発生の要因 設定パラメータが間違っている 

対処法 設定パラメータの確認 

 

項目番号 １４ 

エラーメッセージ FW Update TimeOut 

エラー内容 Firmware アップデートに失敗 

エラー発生の要因 ・SVO ボードが処理中 

・ファイルデータが不正 

対処法 ・SVO ボードの処理を終了させる 
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・ファイルを確認する 

 

項目番号 １５ 

エラーメッセージ FPGA Update TimeOut 

エラー内容 FPGA アップデートに失敗 

エラー発生の要因 ・SVO ボードが処理中 

・ファイルデータが不正 

対処法 ・SVO ボードの処理を終了させる 

・ファイルを確認する 

 

項目番号 １６ 

エラーメッセージ Image Data Not Stored In SVO 

エラー内容 SVO ボードのメモリーにデータが格納されていない 

エラー発生の要因 SVO ボードのメモリーにデータが格納されていない 

対処法 SVO ボードへデータを転送する 

 

項目番号 １７ 

エラーメッセージ Command Busy 

エラー内容 SVO ボードが処理中 

エラー発生の要因 SVO ボードが処理実行中 

対処法 SVO ボードが処理が終了するまで待つ 

 

項目番号 １８ 

エラーメッセージ Command Incorrect 

エラー内容 規定されていないコマンドを SVO ボードに送った 

エラー発生の要因 規定されていないコマンドを SVO ボードに送った 

対処法 送信コマンドの確認 

 

 

8. FRM形式のデータフォーマット 
 

FRM 形式はカメラモジュールまたはイメージセンサから出力されたデータをフレームごとに 40 バイトのヘッダが付加され

たもので、フレームの前にヘッダが記録されます。 

データ部はカメラから出力されたままを記録します。但しフレーム部のバイト数は 64 で割り切れるようパディングデータが

付加されています。 

以下に、FRM 形式の画像ファイルフォーマットの詳細を示します。 
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画像の階調が 10ビット、12ビット、16 ビットのバイト並びはビックエンディアンとなります。 

 

 

9. リストを作って連続再生する 
プレイリストを作って、複数の FRM ファイルや AVI ファイルを連続再生することができます。連続再生は、拡張子 .AVIT 

または .FRMT のリストファイルを読むことで行います。AVIT/FRMT ファイルはテキスト形式で AVI/FRM ファイル名を絶対

パス付で記録したものです。AVI 形式のリスト再生は AVIT、FRM ファイルのリスト再生は FRMT という拡張子としてくださ

い。AVI/FRM ファイルが混在したリストは再生できません。 

 

 例）C ドライブ直下の Dataというフォルダに FRM ファイルが 2 つある場合 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

FRMT ファイルはテキスト形式ですので、Notepad などのテキストエディターなどで編集ができます。上記ように
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FRM ファイルが 2 つしかなくても以下のように同じ FRM ファイルを複数行にすることで長時間の出力が可能となり

ます。出力は FRMT ファイルの記述通りの順番で出力されます。 

 

 例）C ドライブ直下の Dataというフォルダに FRM ファイルが 2 つあって、同じファイルを 

   3 回コピーして長時間出力に対応する場合 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 
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