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1. Outline 

 

 This document is a software Manual of "SVOGenerator" dedicated to the board 

"SVO-MIPI" to convert the video signal from USB 3.0 to the MIPI CSI-2 signal. 

SVOGenerator (hereinafter referred to as the software) of the SVO-MIPI board is based 

on our existing board (SVO-03) SVOGenerator, and many of the user interfaces are 

common. 

Although the software can control existing boards, it is not possible to control the 

SVO-03-MIPI using the SVOGenerator supplied with the existing board. If you have already 

installed SVOGenerator, you will need to install the software separately or replace the software. 

The specifications for this document may be changed without prior notice. It also includes descriptions of the features that 

are not implemented in the product. In addition, there is an explanation of "HDMI version" in this document, but the "HDMI 

version" is an optional function, and it is under development now. 

 

1.1. System Configuration Diagram 

System Configuration Diagram 

 

 

1.2. Operating Environment 

OS      ： Windows7/8.1 64bit/32bit 

Others   ： Our applications, Library 

      Device Driver(8.1 : 64bit only) 

 

1.3. Software Required 

The following software is provided for the operation of the SVO system. 

 

・SVOGenerator.exe 

  This is an application for outputting video files stored on a PC to a SVO-MIPI/SVO-03 board. 

 

Host PC 

Windows7, 8.1 32bit/64bit  
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・SVOUSB30.dll 

  The SVO video Output library is a dedicated USB 3.0 device driver for the SVO system. 

  You can also incorporate the library into customer's system without using the above application. 

 

・SVOUSB30.sys、SVOUSB30.inf 

  32bit version of the SVO system dedicated USB 3.0 device driver file. 

 

・SvoU3drv.dll、SvoUdrv.inf 

  64bit version of the SVO system dedicated USB 3.0 device driver file. 

 

- After SVOGenerator is finished, the following files are generated. 

 

・SVOGenerator.ini 

  Save the information in the File-option dialog mainly. 

 

・SVOGenerator.svo 

  Save the information in the Device-Setting dialog mainly. 

 

 

2. Installation 

 

Contains the software required for the software CD-ROM that is shipped with the SVO-MIPI hardware. The contents of 

this CD-ROM are shown in the table below. 

 

Folder Contents 

\ readme.txt and version.txt 

\SVO-AP_x86 application and library related 

\SVO-AP_x64 the 64bit version above 

\Driver_x86 SVO dedicated USB 3.0 device driver-related 

\Driver_x64 the 64bit version above 

\DOC various documents 

\Library  Video output library file 

\Tool Frame file converter utility 

 

2.1. Installing the SVO dedicated USB 3.0 device driver 

 

1. Connect the SVO-MIPI board and PC's USB 3.0 port with a USB 3.0 cable. 

 

2. Start Device Manager, and then double-click "SVO-09" below "Other devices". 
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3. The "SVO-09 Properties" dialog will appear, so click the "Update Driver" button. 

 

 

4. Click "Browse my computer for driver software". 
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5. Insert the CD-ROM into the disc drive, select the "Driver_SVO\Driver_x64" folder (when 64bit OS) with the "Browse" 

button, and click "Next". 

 

 

6. After a while, the installation is finished. 

 

 

7. After successful installation, "SVO-09" is created in the SVO class. 

 

 

- Driver installation to 32bit OS should be used with device drivers stored below the CD-ROM SVO_Driver\Driver_x86. 
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2.2. Application, library-related installation 

 

Copy the "SVO-AP_x64" folder from the CD-ROM to any location on your hard disk. 

Please make sure that the attributes of the destination "SVO-AP_x64" folder are read/write. 

 

- The Windows7 32bit version is stored in the CD-ROM "SVO-AP_x86" folder. The usage is identical. 

 

3. Uninstall 
 

3.1. Uninstalling device drivers 

 If you need to uninstall the SVO dedicated device driver, remove SVO-09 in Device Manager. Check "Delete the driver 

software for this device" as shown below. 

 

3.2. Application, library-related uninstallation 

Delete the copied SVO-AP_x64 or SVO-AP_x86 folder. 

 

4. DIP Switch Setting 

If more than one SVO board is connected to a PC, the state of DIP SW (SW2) on each board can be used to assign and 

identify the ID.  DIP SW Status and ID assignment list are as follows: 

 

ID #8 #7 #6 #5 #4 #3 #2 #1 Device-Select 

Display 

About Dialog 

Display 

0 OFF OFF OFF OFF OFF OFF OFF OFF 0000 0000xxxx 

1 OFF OFF OFF OFF ON OFF OFF OFF 0001 0001xxxx 

2 OFF OFF OFF ON OFF OFF OFF OFF 0002 0002xxxx 

3 OFF OFF OFF ON ON OFF OFF OFF 0003 0003xxxx 

4 OFF OFF ON OFF OFF OFF OFF OFF 0004 0004xxxx 

5 OFF OFF ON OFF ON OFF OFF OFF 0005 0005xxxx 

6 OFF OFF ON ON OFF OFF OFF OFF 0006 0006xxxx 

7 OFF OFF ON ON ON OFF OFF OFF 0007 0007xxxx 
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5. How to operate the application 
Describes the flow and individual operation of a basic application operation using SVOGenerator. See also application 

Help for more information on application items. 

 

5.1. Application Operation Flow 

The basic flow from the SVO-MIPI board to the output of the video signal is shown below. The operation of each item 

is shown in 5.2 and above. 

 

 

USB Mode                              HDMI Mode 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Launching the application (SVOGenerator) 

File options (analysis information) 

settings 

Read Data file 

Data Confirmation 

SVO Board Selection 

Setting of output timing, etc. 

Start of video signal output 

Stop of video signal output 

End of application (SVOGenerator) 

Launching the application (SVOGenerator) 

 

SVO Board Selection 

SVO Board Setting information creation 

Data transmission to the SVO board 

End of application (SVOGenerator) 
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5.2. Launching the application (SVOGenerator) 

 

① Run "SVOGenerator.exe" in the "SVO-AP_x??" folder that you copied in the "Applications, library-related 

Installation" section. 

② The "SVOGenerator" screen appears, as shown in the figure below. 

 

 

This is the end of the boot. 

 

 

5.3. File options (analysis information) settings 

 

① Click File-> Option or click the  icon on the toolbar. 

② The file Option dialog is displayed so that the settings corresponding to the video files to be read will be made. 
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- Picture Type: Specifies the pixel format of the video file. 

- RAW bit width: Picture Type : When RAW, specifies a bit depth per pixel. 

- ViewPlaySpeed: Specifies the video update interval when the data is checked. 

 The frame rate of the output video data is not reflected. 

③When setting is finished, click the  "OK" button. 

- Be sure to set the file options before reading the video file. 

 

5.4. Reading video files 

① Click File-> Open or click the   icon on the toolbar. 

② The Open File dialog box appears, and then select the appropriate file. 

 

Corresponds to the .frmt, .frm, .avi file extension. 

If you open an AVI file, FourCC must be either  "YUY2",  "UYVY",  "DIB ". 

③ Analyze the data based on the File option setting. When analysis is finished, the image is displayed on the 

screen. 

 

- "Analyze complete" appears in the status bar when the analysis completes successfully. 

The status bar displays  "Analyze incomplete" If the analysis is prematurely terminated 

- If the color is incorrect in YUV, please try to change the order in File-option. 
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5.5. Verifying video data 

 

① View-> Play or select the  icon on the toolbar to check the data one frame at a time. 

  

② The status bar displays the currently displayed frame number and image size. 

③ If you want to check the frame of the image data while skipping  "view" ->  "Jump to" 

If you want to check the color of the image data  "view"->  "Color Bar" 

If you want to check the header information "view"->  "File information" 

Please check. 

For more information on the status bar and dialogs, see SVOGenerator Help. 

 

5.6. SVO Board Selection 

 

① Click Device-> Select, or press F3 on the keyboard or  on the toolbar. 
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② "Device Select" dialog is displayed. The identification ID of the SVO board that is currently connected to the 

USB port is displayed in the drop-down list, so select the ID of the board you want to control. 

 

③ Press the "Select" button. 

 

 

 

5.7. Setting the output timing, etc.  

① Click Device-> Setting, or press F4 on the keyboard, or the  icon on the toolbar. 

  

② "Device Setting" dialog appears. Set each setting item. For configuration items, refer to  "6 Device Setting dialog ". 
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- Because the selected board has different settings, you must select the board from the "Device Select" dialog before 

displaying the "Device Setting" dialog. 

- Press the "SAVE SET" button to save the current settings to any file. 

- When you press the "RESTORE SET" button, you can read the settings saved by "SAVE SET". 

 

③ When you're done, press the Apply button. 

 

This is the end of the setup. 
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5.8. Video signal output control 

① Click Device-> Control, or F6 on the keyboard, or the  icon on the toolbar. 

  

 

② When the "Device Control" dialog opens, the video frames are transferred to the DRAM on the board first. 

When the "Play" button is enabled, it is ready for transfer. 

 

- Play cycle: If it is checked, repeat video output. 

- Play mode: If it is checked, the entire AVI file in the PC will be output sequentially through the DRAM frame 

buffer on the board. If it is not checked, only the beginning of the AVI file is transferred to the DRAM on the board, 

and the DRAM contents are output repeatedly. 

- Image sync: If it is checked, the SVOGenerator side screen is updated every second at the same time as the 

output. 

- External Trigger: Video output start trigger input is enabled. 

- External V/HSync: When the video is output, the output is synchronized to the V/Hsync signal of the external 

input. 

- External PCLK: When the video is output, the output is synchronized to the PCLK signal of the external input. 

- Trigger Out: Outputs a video output trigger signal to be used for multiple ch simultaneous output. 

 

③ Press the "Play" button to start the video output. 
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④ When the video output starts, the "Play" button is disabled and the "Current Position" is counted up to "Total 

output Frames". 

You can stop the video output by pressing the "Stop" button during the video output. Once all the files have been 

transferred, the "Play" button is enabled again. 

 

6. Device Setting Dialog (SVO-MIPI ) 

 

 

- Press the "SAVE SET" button to save the current settings to any file. 

- When you press the "RESTORE SET" button, you can read the settings saved by "SAVE SET". 

- Press the "Easy Timing Generator..." button to open a dialog that allows you to easily set the "Video Timing Setting" 

setting. 

- When you press the "Apply" button, the current settings are sent to the board. 

 

 When you click the Device Setting menu with the SVO-MIPI board selected in the Board Select dialog, you will see a device 

Setting dialog like the one above. This dialog setting allows you to set the timing and format of the video signal. In order to 

properly set the output timing of the SVO-MIPI, it is necessary to understand the video output configuration of the board to 

some extent. 

 As shown below, the SVO-MIPI board has a two-stage video output block inside the FPGA.  The first stage video signal 
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generator generates a 32-bit parallel video signal, and the second stage MIPI signal converter Serializes the parallel video 

signal to the serial signal. The serial signal is outputted outside the board as a MIPI CSI-2 signal via the MIPI D-PHY. The 

timing relationship between the parallel signal and MIPI CSI-2 signal is shown below. 

 

 The timing relationship between the parallel signal and MIPI CSI-2 signal is shown below. In the figure below The timing 

parameter shown in the timing chart of the (1)Parallel Signal reflects the setting item of the same name in the "Device 

Setting" dialog. The names and functions of these timing parameters are the same as those of the parallel SVO-03 board. 

 

- FE: Frame End, FS: Frame Start, PH: Packet Header, PF: Packet Footer 
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6.1. Device Setting Dialog Configuration Items 

The settings for the "Video Timing Setting" set the timing of the parallel signal. MIPI output Timing settings are all done by 

timing adjustment of these parallel signals. 

Setting items Description Unit 

VSSP (See above figure) PCLK 

VSPP (See above figure) PCLK 

HSSP (See above figure) PCLK 

HSPP (See above figure) PCLK 

HSIP (See above figure) PCLK 

HSPR Specifies the number of repetitions of the HSync signal.  

DESP (See above figure) PCLK 

DEPP (See above figure) 

If the pixel format is YUV4:2:2 8bit, RAW10, RAW12, you must specify half the 

width of the input video file. 

If the pixel format is RGB888, RAW20, you must specify a value equal to the width 

of the input video file. 

PCLK 

DEIP (See above figure) PCLK 

DEPR Specifies the number of repetitions of the Data Enable signal. 

You must specify the same value as the height of the input video file. 

 

Parallel PCLK Specifies the pixel clock for the parallel signal. MHz 

- If you want to set the number of clocks set to Parallel PCLK from other than the set value in the list box, please contact us 

separately. 

- If you set the wrong timing, the output of the video signal may not be performed. 

- For more information about timing, see the hardware specifications for the SVO-MIPI board. 

 

 "MIPI CSI-2 Setting" configuration item sets the parameters and pixel format of the MIPI CSI-2 signal. 

Setting items Description Unit 

Pixel Format Specifies the pixel format.  

Data Rate Specifies the bit rate per lane. 

Specify a value that satisfies the board's specifications. 

Mbps 

Lane Count Specifies the number of lanes. Lane 

Continuous Clock When it is checked, the CLK Lane is output with HS fixed. 

usually uncheck. 

 

 

Press the "Easy Timing Generator..." button to open the dialog (MIPI Easy Timing Generator dialog) to easily set settings for 

"Video Timing Setting". 
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 When you press the OK button above, the timing of the parallel signal is automatically generated based on the input video 

resolution, pixel format, and frame rate, and set to the item of the original dialog. 

 

 

7. Update the Board 

The SVO-03-MIPI board can update firmware and FPGA configurations via USB. The update procedure is as follows. 

1. Connect the SVO-03-MIPI board to the PC, with DIP SW (SW1) number 7 ON and number 8 OFF. 

2. Because it works with a different driver than the USB mode, you should install the driver manually from Device 

Manager when you first start it. 

1. "Other Devices" → "SVM-03U" and click "Update driver" 

 

2. Click "Browse your computer to find driver software" 

3. Select the driver folder (Driver_SVI or Driver_SVM) and click “Next”. 

3. Start "SVMCtl" and click "SVM Setting...". 
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4. Select "Multi Update..." and select the update image to start the update. 

 

5. The update will take several minutes. Do not unplug the USB cable or turn off the PC. 

6. When the update message exits, exit "SVMCtl" and unplug the USB cable. 

7. The DIP SW is restored and the update is complete. 

 

 

8. FRM Format data format 
 

The corresponding image data in the SVO system is general AVI format or the FRM format created by the SVI system. 

The FRM format is the data output from the camera module or image sensor, with a 40-byte header appended to each 

frame. The header is recorded at the beginning of the frame. 

The data part records the output from the camera. However, the padding data is appended so that the number of bytes in 

the frame portion is divisible by 64. 

The following are the details of the FRM format image File format: 
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The image has 10-bit, 12-bit, 16-bit bytes, and is big-endian. 

 

The FRM file has a limit of 2GB, so if it is more than one FRM file, then use the FRMT file to manage it. The FRMT file is 

a text format that records the FRM file name with an absolute path. 

 

 Example) if you have two FRM files in a folder called Data under C drive 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

Because the FRMT file is in text format, you can edit it in a text editor such as Notepad. Even if there 

are only two FRM files, it is possible to output for a long time by selecting multiple lines of the same 

FRM file as follows. The output will be output in the order as described in the FRMT file. 

 

 Example) if you have two FRM files in a folder called Data under C drive, and you copy the same file three 

Example) dump the top 112 bytes of FRM format data at Raw-10bit 

Header 

Data 

Frame 1 

Frame 2 

Frame 3 

Frame 3 header 

Frame 2 header 

Frame 1 header 

Frame 2 data 

Frame 1 data 

Frame 3 data 

Padding 

Padding 

Padding 

 
Image format 

 
Header configuration 

 
Data configuration 

 

 

 
 
 
 
 
 
 
 

Image width 

Image Height 
Image tone(8, 10, 12) 
Reserve (0) 
Frame number (from 0) 
Frame data bytes (does not include padding) 
Image format 
Timestamp (not used) 
Reserve (0) 
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times to respond to long-term output 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

C:\Data\data0001.frm 

C:\Data\data0002.frm 

 


